2010-08-03 01:31:47     About blackfin toolchain installation

Document created by Aaronwu Employee on Sep 26, 2013
Version 1Show Document
  • View in full screen mode

2010-08-03 01:31:47     About blackfin toolchain installation

Zechao Wang (AFGHANISTAN)

Message: 92083   

 

Hello, i feel confused when install toolchain even have read the doc :

http://docs.blackfin.uclinux.org/doku.php?id=toolchain:installing

 

The following is my combination ( the latest toolchain ):

 

 

1. If i want to install

v4.1.2

 

bfin-uclinux-gcc and bfin-elf-gcc, i need to install:

 

    blackfin-toolchain-09r1.1-2.i386.tar.bz2

    blackfin-toolchain-elf-gcc-4.1-09r1.1-2.i386.tar.bz2

    blackfin-toolchain-uclibc-default-09r1.1-2.i386.tar.bz2 (or "full" version)

 

 

2. If I want to install

v4.3.3

 

bfin-uclinux-gcc and bfin-elf-gcc, i need to install:

 

    blackfin-toolchain-gcc-4.3-addon-09r1.1-2.i386.tar.bz2

    blackfin-toolchain-elf-gcc-4.3-addon-09r1.1-2.i386.tar.bz2

    blackfin-toolchain-uclibc-default-gcc-4.3-addon-09r1.1-2.i386.tar.bz2 (or "full" version)

 

 

Am i right ?

 

And do i have installed completed ?

TranslateQuoteReplyEditDelete

 

 

2010-08-03 02:18:34     Re: About blackfin toolchain installation

Mike Frysinger (UNITED STATES)

Message: 92085   

 

you cannot install the 4.3 toolchain only.  it is either 4.1 only or 4.1 & 4.3 at the same time.

QuoteReplyEditDelete

 

 

2010-08-03 03:25:49     Re: About blackfin toolchain installation

Steve Kilbane (UNITED KINGDOM)

Message: 92102   

 

To put it another way (following on from Mike's comment): the 4.3 packages are called "addon" because all they contain is the 4.3 compiler bits. Everything else you need for the toolchain besides the compiler is just in the 4.1 package.

 

steve

QuoteReplyEditDelete

 

 

2010-08-03 04:27:14     Re: About blackfin toolchain installation

Zechao Wang (AFGHANISTAN)

Message: 92104   

 

Thanks very much.

 

My first combination should works, right ?

 

Another question:

 

Each *-4.3-addon-* package is depend on the relative *-4.1-* package. So, if one want to install *-4.3-addon-*, the relative *-4.1-* package should be installed first ?

TranslateQuoteReplyEditDelete

 

 

2010-08-03 12:56:18     Re: About blackfin toolchain installation

Mike Frysinger (UNITED STATES)

Message: 92113   

 

yes

Attachments

    Outcomes