2010-03-30 01:12:19     bf561 problem in booting process

Document created by Aaronwu Employee on Sep 26, 2013
Version 1Show Document
  • View in full screen mode

2010-03-30 01:12:19     bf561 problem in booting process

Suganiya K (INDIA)

Message: 87814   

 

hi all,

 

I am using 2008r1 toolchain for BF561 processor. I am able to load the uImage on the board, but after giving "bootm" i am getting the following message....

 

Entry Point: 0021a000

 

Verifying Checksum ... OK

 

Uncompressing Kernel Image ...

 

LoadAddr:00100000, unc_len:4000000, data:00d00040 len:227709

 

after which many Garbage value are displayed.

 

Can anyone help me to sort out  the problem which i am facing.

 

Thanks

 

suganiya

QuoteReplyEditDelete

 

 

2010-03-30 01:23:38     Re: bf561 problem in booting process

Mike Frysinger (UNITED STATES)

Message: 87815   

 

most likely your baud rate is incorrect.  fix your bootargs.

QuoteReplyEditDelete

 

 

2010-03-30 02:58:40     Re: bf561 problem in booting process

Suganiya K (INDIA)

Message: 87820   

 

Hi Mike,

 

Thanks for your reply kindly tell how to use the "bootargs", or give me the link.. to learn and do the process.

 

Thanks

 

Suganiya

QuoteReplyEditDelete

 

 

2010-03-30 03:22:34     Re: bf561 problem in booting process

Mike Frysinger (UNITED STATES)

Message: 87844   

 

we have a wiki -- please use the search function

 

http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:env

QuoteReplyEditDelete

 

 

2010-03-30 09:39:52     Re: bf561 problem in booting process

Suganiya K (INDIA)

Message: 87855   

 

Hi Mike,

 

   Thanks for giving me the link. i have used the bootargs. Still i am facing the same problem.

 

set bootargs root=/dev/mtdblock2 clkin_hz=25000000 earlyprintk=serial,uart0,9600 console=ttyBF0,9600

 

set bootargs root=mtd0 rootfstype=romfs ro console=ttyBF0,9600

 

i have used both the commands, but still the board is responding with the garbage value.

 

Please help me giving some guidelines.

 

Thanks

 

Suganiya

QuoteReplyEditDelete

 

 

2010-03-30 15:04:11     Re: bf561 problem in booting process

Mike Frysinger (UNITED STATES)

Message: 87859   

 

show some actual output of what you're doing.  also, post the full kernel boot log:

http://docs.blackfin.uclinux.org/doku.php?id=linux-kernel:debug:post_mortem

QuoteReplyEditDelete

 

 

2010-03-30 15:05:00     Re: bf561 problem in booting process

Robin Getz (UNITED STATES)

Message: 87860   

 

Suganiya:

 

What hardware do you have? Something looks broken... (version of board, version of chip, serial cable, host, etc).

 

-Robin

Attachments

    Outcomes