[#7195] SD fails to be detected after bf609 ezkit board has run serverall round of testing.

Document created by Aaronwu Employee on Sep 26, 2013
Version 1Show Document
  • View in full screen mode

[#7195] SD fails to be detected after bf609 ezkit board has run serverall round of testing.

Submitted By: Mingquan Pan

Open Date

2012-07-09 23:03:01     Close Date

2012-07-12 05:49:37

Priority:

Medium     Assignee:

Sonic Zhang

Category:

N/A     Fixed In Release:

N/A

Found In Release:

N/A     Status:

Closed

Board:

N/A     Processor:

BF609

Silicon Revision:

    Resolution:

Assigned (Not Start)

Is the bug repeatable?:

N/A     

Summary: SD fails to be detected after bf609 ezkit board has run serverall round of testing.

Details:

 

SPI mmc fails to be detected after bf609 ezkit board has run serveral round of testing.

 

CPU:   ADSP bf609-0.0 (Detected Rev: 0.0) (parallel flash boot)^M

Board: ADI BF609 EZ-Kit board^M

       Support: http://blackfin.uclinux.org/^M

Clock: VCO: 25 MHz, Core: 500 MHz, System0: 100 MHz, System1: 100 MHz, Dclk: 125 MHz^M

RAM:   128 MiB^M

Flash: 16 MiB^M

MMC:   Blackfin SDH: 0^M

In:    serial^M

Out:   serial^M

Err:   serial^M

other init^M

Net:   mii0^M

Hit any key to stop autoboot:  9 ^H^H^H 0 ^M

bfin> waiting for uboot prompt

^M

bfin> got u-boot prompt

icache on^M

Instruction Cache is ON^M

bfin> dcache off^M

Data (writethrough) Cache is OFF^M

bfin> reginfo^M

^M

System Configuration registers^M

^M

CGU Registers^M

        CGU_DIV:   0x44042521   CGU_CTL:      0x00001400^M

        CGU_STAT:  0x000003f5   CGU_LOCKCNT:  0x00000000^M

^M

SMC DDR Registers^M

        DDR_CFG:   0x00000422   DDR_TR0:      0x20705212^M

        DDR_TR1:   0x201003cf   DDR_TR2:      0x00320107^M

        DDR_MR:    0x00000422   DDR_EMR1:     0x00000004^M

        DDR_CTL:   0x00000900   DDR_STAT:     0x00402007^M

        DDR_DLLCTL:0x0000044b^M

bfin>

*****************************

STEP 37: Test MMC/SD

 

mmc rescan 0^M

sending CMD2 failed^M

bfin> mmcinfo^M

sending CMD2 failed^M

Device: Blackfin SDH^M

Manufacturer ID: 0^M

OEM: 0^M

Name: Tran Speed: 0^M

Rd Block Len: 0^M

SD version 2.0^M

High Capacity: No^M

Capacity: 0 Bytes^M

Bus Width: 1-bit^M

bfin> fatls mmc 0^M

MMC: block number 0x1 exceeds max(0x0)^M

** Can't read from device 0 **^M

^M

** Unable to use mmc 0:1 for fatls **^M

bfin> ERROR: can not find uimage

 

Follow-ups

 

--- Mingquan Pan                                             2012-07-12 06:49:23

It is a board issue. After changing to a new board, this problem is gone.

So close.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes