[#6879] 526 ezbrd fails to detect spi flash

Document created by Aaronwu Employee on Sep 26, 2013
Version 1Show Document
  • View in full screen mode

[#6879] 526 ezbrd fails to detect spi flash

Submitted By: Mingquan Pan

Open Date

2011-11-14 02:41:51     Close Date

2013-05-16 01:41:40

Priority:

Medium     Assignee:

Scott Jiang

Category:

N/A     Fixed In Release:

N/A

Found In Release:

2011R1     Status:

Closed

Board:

N/A     Processor:

BF526

Silicon Revision:

    Resolution:

N/A

Is the bug repeatable?:

N/A     

Summary: 526 ezbrd fails to detect spi flash

Details:

 

526 ezbrd fails to detect spi flash.

 

U-Boot 2010.06-svn2479 (ADI-2010R1) (Oct 19 2010 - 01:00:03)

 

CPU:   ADSP bf526-0.0 (Detected Rev: 0.0) (parallel flash boot)

Board: ADI BF526 EZ-Board board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 400 MHz, Core: 400 MHz, System: 80 MHz

RAM:   64 MiB

Flash: 4 MiB

In:    serial

Out:   serial

Err:   serial

KGDB:  [on serial] ready

Net:   bfin_mac

Hit any key to stop autoboot:  0

bfin> tftp 0x2000000 u-boot.bin

Using bfin_mac device

TFTP from server 10.100.4.174; our IP address is 10.100.4.50

Filename 'u-boot.bin'.

Load address: 0x2000000

Loading: ###############

done

Bytes transferred = 213768 (34308 hex)

bfin> go 0x2000000

## Starting application at 0x02000000 ...

 

 

U-Boot 2011.09-dirty (ADI-2011R1) (Nov 14 2011 - 14:49:09)

 

CPU:   ADSP bf526-0.0 (Detected Rev: 0.0) (spi flash boot)

Board: ADI BF526 EZ-Board board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 400 MHz, Core: 400 MHz, System: 80 MHz

RAM:   64 MiB

Flash: 4 MiB

SF: Unsupported manufacturer ff

*** Warning - spi_flash_probe() failed, using default environment

 

In:    serial

Out:   serial

Err:   serial

KGDB:  [on serial] ready

Net:   bfin_mac

Hit any key to stop autoboot:  0

bfin> sf probe 1

SF: Unsupported manufacturer ff

Failed to initialize SPI flash at 0:1

 

Follow-ups

 

--- Scott Jiang                                              2011-11-25 04:09:55

0.1 board works

 

--- Sonic Zhang                                              2011-11-25 04:26:00

Looks a hardware issue on bf526-ezbrd v1.1. Please test on 0.1.

 

--- Mingquan Pan                                             2011-12-12 04:47:25

The issue exists on 526 board with 0.2 chip.

 

U-Boot 2011.09 (ADI-2011R1) (Dec 12 2011 - 16:48:26)

 

CPU:   ADSP bf526-0.0 (Detected Rev: 0.2) (parallel flash boot)

Board: ADI BF526 EZ-Board board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 400 MHz, Core: 400 MHz, System: 80 MHz

RAM:   64 MiB

Flash: 4 MiB

In:    serial

Out:   serial

Err:   serial

KGDB:  [on serial] ready

Net:   bfin_mac

Hit any key to stop autoboot:  0

bfin> tftpboot 0x1000000 u-boot.bin

Using bfin_mac device

TFTP from server 10.100.4.174; our IP address is 10.100.4.50

Filename 'u-boot.bin'.

Load address: 0x1000000

Loading: ###############

done

Bytes transferred = 213788 (3431c hex)

bfin> go 0x1000000

## Starting application at 0x01000000 ...

 

 

U-Boot 2011.09-svn2725 (ADI-2011R1-pre) (Oct 14 2011 - 12:20:12)

 

CPU:   ADSP bf526-0.0 (Detected Rev: 0.2) (spi flash boot)

Board: ADI BF526 EZ-Board board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 400 MHz, Core: 400 MHz, System: 80 MHz

RAM:   64 MiB

Flash: 4 MiB

SF: Unsupported manufacturer ff

*** Warning - spi_flash_probe() failed, using default environment

 

In:    serial

Out:   serial

Err:   serial

KGDB:  [on serial] ready

Net:   bfin_mac

Hit any key to stop autoboot:  0

 

--- Mingquan Pan                                             2013-05-16 02:48:29

It can pass in 2012R2 on 526 board with 0.2 chip. Close.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes