Bandwidth mismatch between photodiode wizard and LTSpice

Hello,

Attached is a design from the photodiode wizard tool. It is a two stage design. When second stage is non-inverting, -3dB bandwidth from the tool (fN) roughly matches with that from LTspice. However, when the second state is inverting, the tool reported bandwidth is way off (tool is at least 3 dB more optimistic than LTspice). I tried with two different second stage opamps LTC6228 as well as LTC6252 and both have problems. It almost looks like the tool is not comprehending bandwidth degradation on the first stage as a result of low load impedance Rg gain resistor of the second stage.

Can some one please look into it? 

It looks like this site does not like to upload the .json file generated by the tool. In any case, here are the relevant inputs to tool to replicate the issue:

Photodiode bias (change this from positive to negative to see the issue), 200 nA peak current, 4G shunt, 900fF capacitance, 200mV peak voltage, Bandwidth 72MHz, Q =0.66, 2-stage design, 1st stage LTC6268-10, 2nd stage LTC6228 or LTC6252, expected fN = ~38.5MHz. Ideally, fN should match with -3dB from LTspice.

(On a separate minor issue, fN reported from Circuit Design -> Frequency Response Tab of the tool does not match with fN reported under Next Steps -> Frequency Response Tab. I think the latter reporting is incorrect.)

Thanks and regards,

Satish

Parents Reply Children
  • test_case_0.zip

    Hello Helmut,

    I have attached the zipped .json file. What should the asc file contain? 

    I've already mentioned above the inputs to set for the tool.

    Regards,

    Satish 

  • 0
    •  Super User 
    on May 19, 2020 8:40 PM 9 months ago in reply to Satish A

    Hello Satish,

    The target bandwidth of 58MHz has not been achieved in the Design Wizard. One can see this in the exported Excel-file (-3dB@29MHz). I wonder why there is no warning in the wizard.

    I have analyzed the same circuit with LTspiceXVII.

    The bandwidth of the TIA-amplifier has been 38MHz in LTspiceXVII when connected to the second amplifier.
    (When I remove the following load (35.7Ohm resistor), the simulated bandwidth has been 48MHz.)
    The simulated overall bandwidth in LTspiceXVII has been 20.6MHz instead of the 29MHz as calculated by the wizard.

    Maybe the "Photo Diode Circuit Design Wizard" only use a first order gain model with -20dB/decade.  When I use the model "opamp" bor both opamps and set its GBW to 4GHz and 0.55pF from +in to GND at the TIA, then I got 48MHz bandwidth for the TIA-stage and an overall bandwidth of 31Mhz at the ouput of the second opamp. The overall bandwidth of the 31MHz well agrees with the 29MHz in the plot of the frequency response in the Design Wizard.
     

    The zip-file contains the files for LTspiceXVII.

    Let's hope I haven't done any mistake in my investigation.

    Helmut

    tia1.zip