Bugs in spice models

1. I downloaded spice model of AD8061 and connected it to LTSpice. I found that the input currents
of the op amp have the opposite polarity.

2. I found that the AD8038 is modeled incorrectly in LTspice. It seems that some pins are mixed up.

How can I attach schematics of LTspice?

Where can I write to correct spice models? The letter sent to LTspice@analog.com did not help.

Parents
  • 0
    •  Super User 
    on Apr 29, 2020 11:04 AM in reply to dinam

    Hello Hooman,

    Thanks for your report.

    I have simulated with your examples.

    AD8061

    The input current in the simulation is +3.5uA. The datsheet also shows the same Ibias=+3.5uA.
    I also doubt that the sign of the bias current is correct. Every bipolar amplifier with an input range down to the negative supply has PNP transistors at the input. This means the bias current is normally negative. See figure 40 in the datasheet of  the AD8051. https://www.analog.com/media/en/technical-documentation/data-sheets/AD8051_8052_8054.pdf
    Even in this datasheet, there is a positive bias current specified. I wonder about that.

    Hello ADI-support,
    please check the direction of the bias current with the responsible department.
    If somebody has a test board, he could easily check this and report the result.

    AD8038

    The pins have been correctly set in the symbol. It's OK in my opinion.

    The "Input Common Mode Voltage" range is from 1V above the negative supply to 1V below th epositive supply. Please connect at least -1V on the negative supply pin, because your input voltga is close to 0V.

    The typical input current is 400nA in the datasheet. The input current in the simulation has been about -100nA with nearly 0V input and the -1V supply. I wonder why it depends directly on the common mode voltage, but I can't check this due to the missing schematic of the internal circuit. Based on the model the input bias current is
    Iin = (Vin - (V(cc+Vss)/2)/10MegOhm. 

     

    Helmut

Reply
  • 0
    •  Super User 
    on Apr 29, 2020 11:04 AM in reply to dinam

    Hello Hooman,

    Thanks for your report.

    I have simulated with your examples.

    AD8061

    The input current in the simulation is +3.5uA. The datsheet also shows the same Ibias=+3.5uA.
    I also doubt that the sign of the bias current is correct. Every bipolar amplifier with an input range down to the negative supply has PNP transistors at the input. This means the bias current is normally negative. See figure 40 in the datasheet of  the AD8051. https://www.analog.com/media/en/technical-documentation/data-sheets/AD8051_8052_8054.pdf
    Even in this datasheet, there is a positive bias current specified. I wonder about that.

    Hello ADI-support,
    please check the direction of the bias current with the responsible department.
    If somebody has a test board, he could easily check this and report the result.

    AD8038

    The pins have been correctly set in the symbol. It's OK in my opinion.

    The "Input Common Mode Voltage" range is from 1V above the negative supply to 1V below th epositive supply. Please connect at least -1V on the negative supply pin, because your input voltga is close to 0V.

    The typical input current is 400nA in the datasheet. The input current in the simulation has been about -100nA with nearly 0V input and the -1V supply. I wonder why it depends directly on the common mode voltage, but I can't check this due to the missing schematic of the internal circuit. Based on the model the input bias current is
    Iin = (Vin - (V(cc+Vss)/2)/10MegOhm. 

     

    Helmut

Children