Eye Diagram

I can get an eye diagram with the option ".options baudrate=rate". but the menu Plot Settings->Eye Diagram->Enable and Plot Settings-Eye Diagram->Properties are grayed out. I guess you can switch the normal view and eye diagram and also shift the eye location with through menu. Is there someboday who knows how you can bring up those menus? 

  • 0
    •  Analog Employees 
    on Dec 4, 2018 2:06 PM over 1 year ago

    KSAITO,

    Can you please specify which tool you are referring to, so the correct people can look at your question?

    -Anne

  • 0
    •  Super User 
    on Dec 4, 2018 2:25 PM over 1 year ago

    Hello KSAITO,

    I fully agree. The function "Plot Settings->Eye Diagram-" is dead even when the eye diagram is enabled.

    .options baudrate=xxx

    Additionally the option delay belonging to the eye diagram doesn't work anymore.

    .options delay=xxx

    These function have worked in LTspiceIV.

    It's a long time since I have used eye diagrams. Thus I don't remember it has worked in LTspiceXVII in older versions.

    Please send a bug report to LTspice@analog.com.

    Best regards,
    Helmut

  • Anne,

    Thanks for your suggestion. I am using the newest version of LTSPICE XVII.  

  • Helmut,

    Thanks for your comment.

    At leaset, the very previous version of XVII has same symptom. I remember these functions are not fully documented, then the developer disabled them intentionally for some reasons. Anyway I will report it.

    Ken 

  • 0
    •  Super User 
    on Dec 5, 2018 12:07 PM over 1 year ago in reply to KSAITO

    Hello Ken,

    I had already reported this case yesterday and I already got two answers from Mike.

    ---

    Hello Mike,

    The function "Plot Settings->Eye Diagram-" is dead (greyed) even when the eye diagram is enabled.

    .options baudrate=xxx

    Additionally the option delay belonging to the eye diagram doesn't work anymore.

    .options delay=xxx

    These function have worked in LTspiceIV.

    It's a long time since I have used eye diagrams. Thus I don't remember it has worked in LTspiceXVII in older versions.

    ---

    1. answer from Mike

    Right click on the horizonal axis and press the Eye Diagram button to set it up.

    2. answer from Mike

    LTspice XVII no longer requires you to set these before the simulation.

    ---

    It looks like Mike has intentionally disabled this function.

    Question for everybody

    Is there any case where we still need this missing function from the GUI?

    Helmut