ADIsimPE License/Update issue

Hi,

I've downloaded the version of ADIsimPE from here, but when I install it, a dialog pops up about the license being expired, and I can't run any sims. So I followed the instructions here, but this does not solve the issue. To elaborate, the version on your site is 8.10, but the 'Check For Updates' dialog says that a new version (8.20) is available. But when I follow the link to download the new version, I end up back at the page with version 8.10 (i.e. the original link here).  How can I get the required version?

Thanks.