Post Go back to editing

Unable to get working using dragonboard 410c and AD-96ToF1-EBZ

Category: Software
Product Number: AD-96ToF1-EBZ
Software Version: Latest Version of the ADITOF_SDK

Hello, I am using the dragonboard 410c with the AD-96TOF1-EBZ time of flight sensor and want to write the example from the ADITOF SDK but keep running into the following error:

File "home/linaro/worksapce/github/aditof_sdk/bindings/python/examples/dnn/", Line 32, in <module>

import aditofpython as tof

ModuleNotFoundError: No module named 'aditfopython'

How do I fix this error? All I need to do is get this dnn exmaple running to display object detection for a project. Steps to solve this issue even from the start after flashing a new SD card would be very helpful.

Thank you.

  • Hello,

    There are 2 ways to solve this:

    First please check if the python bindings are enabled in cmake. (it's the -DUSE_PYTHON flag)

    1) You can either go to the build folder and run sudo make install
    After this you should be able to run the example.

    2) you can copy the aditofpytonadapter* from ~/workspace/aditof_sdk/build/bindings/python next to the script that you want to use.

    Best regards,

  • Thank you for the reply. I appreciate it and I will try this. I have one more issue. While trying to build the openCV libraries, the last commands freeze the terminal every time and can never finish building. The commands needed to be executed as follow:

    sudo apt-get install libgtk-3-dev libvtk6-dev
    git clone --branch 4.5.0 --depth 1
    git clone --branch 4.5.0 --depth 1
    cp -r ./opencv_contrib/modules/viz ./opencv/modules/
    cd opencv
    mkdir build_4_5_0 && cd build_4_5_0
    cmake -DWITH_VTK=ON -DBUILD_opencv_viz=ON -DBUILD_opencv_world=ON -DCMAKE_PREFIX_PATH="/opt/vtk" -DCMAKE_INSTALL_PREFIX="/opt/opencv" ..
    sudo make -j4 && sudo make install

    The last line, specifically: 'sudo make -j4" does not work at all on the dragonboard 410c, it freezes the terminal. I have tried using "-j1", "-j2" and "-j3" and they all freeze.
    How can I install and build openCV?

    Thank you in advance for a reply.
  • An older version of OpenCV should already be installed on the dragonboard image.
    If you want to use a newer version you need to cross-compile the library on a faster platform and copy it to the dragonboard.

    Best regards,

  • So after some troubleshooting, I believe the DNN example will run, but I have one small error it keeps throwing.

    When in the aditof_sdk/bindings/python/examples/dnn directory, I am trying to run the following command:

    python --prototxt \pathTo\MobileNetSSD_deploy.prototxt  --weights \pathTo\MobileNetSSD_deploy.caffemodel

    I tried to replace the "\pathTo" on both to "\linaro@linaro-alip:~/workspace/github/aditof_sdk/bindings/python/examples" and this gave the error:

    "error: please give the correct location of the prototxt and caffemodel"

    Can you let me know how to properly specify the path to the prototxt and caffemodel?

  • Since this has been asked in a different thread, I am closing this.