problem running Eval-AD5535BSDZ and Eval-SDP-CS1Z

Hi,

 

We have purchased several units of Eval-AD5535BSDZ and Eval-SDP-CS1Z. Now we are trying to assemble at least one unit to apply individual DC voltages in 10 different channels.

We plugged our computer (windows 10 OS) to ad5535 via sdp and have installed drivers for Eval-SDP-CS1Z and Eval-AD5535BSDZ. When we launch the AD5535B soft, the following error is triggered: error 1172 system.argumentnullexception

Also, it looks like there is no connection between software and a hardware, and we cannot get any signal at the output of Eval-AD5535BSDZ.

 

Please advise!

 

Thank you and have a nice day!

 

Regards,

Alex

Parents
  • +1
    •  Analog Employees 
    •  Super User 
    on May 28, 2021 6:13 AM

    Hi Alex,

    Did you follow the setup guide in the user guide, EVAL-AD5535BSDZ (Rev. 0) (analog.com)

    What supply voltages did you set?

    Does this happen to all the units you purchased? 

    Let me clarify, the error prompts when you run the software? Is the USB cable to the SDP Board already connected to the PC at this time?

    Best regards,

    Ian

  • Hi Ian,

    Thanks for your reply.

    1. Yes I have followed the setup guide step by step. I checked the device manager after software installation and plugging usb to my computer and sdp. It does indicate that sdp works properly. Both LEDs of SDP are on.

    2. Supply voltages: +5 V on DVcc, AVcc and V+ (LK4 jumper is on); 100 V onVpp.

    3. I tried at least 4 pairs of SDP and AD5535BSDZ. Nothing works.

    4. Yes, the error pops up immediately after launching AD5535B soft. Yes, the SDP is already connected to a PC via USB at that time, and AD5535BSDZ is already powered.

    Regards,

    Alex

Reply
  • Hi Ian,

    Thanks for your reply.

    1. Yes I have followed the setup guide step by step. I checked the device manager after software installation and plugging usb to my computer and sdp. It does indicate that sdp works properly. Both LEDs of SDP are on.

    2. Supply voltages: +5 V on DVcc, AVcc and V+ (LK4 jumper is on); 100 V onVpp.

    3. I tried at least 4 pairs of SDP and AD5535BSDZ. Nothing works.

    4. Yes, the error pops up immediately after launching AD5535B soft. Yes, the SDP is already connected to a PC via USB at that time, and AD5535BSDZ is already powered.

    Regards,

    Alex

Children