Post Go back to editing

AD5753 VDPC– current draw issue

Hi everyone,

we designed an analogue IO module with 16 independent AIO's, divided in 8 groups of 2. Each group of 2 is supplied by an isolated DC converter providing +-20V, 42mA per rail. When testing the board we had some converters magically fail after a while. We use both current and voltage output modes, mixed between all the channels.

After a little research we found that the AD5753's are using considerably more current on the negative rail then on the positive.

If the DCDC_MODE register is set to DPC Current mode, output set to 24mA (through a 500R load), current draw on the positive rail is 19mA. If we set the output to -24mA, the current draw on the negative rail rises to 60mA, then drops to 36mA with a reduced current output (-21.78mA) and reduced Vdpc-.

If the DCDC_MODE register is set to DPC Voltage mode, without any output set, current draw on the negative rail immediately rises to 34mA, whilst the positive rail only increases by 2mA.

In either mode, if we leave it on long enough it goes into a mode were it doesn't even reach its full negative output range. We looked at the board with an FLIR, the DAC was about 65 degrees Celcius. When spraying "Freezer spray" on it, we can get it "working" again. That means, Vdpc- voltage ar the right level, output current at the set current, but still to much current consumption from the negative supply rail. 

We clearly see different behaviors between the Vdpc+ and Vdpc- rails. We took some pictures with our scope:

  • Yellow = Vdpc+
  • Green = Vdpc+ Swithcing Node
  • Pink = Vdpc-
  • Blue = Vdpc- Switching Node

Image 1: DCDC_MODE register in DPC Voltage mode, no output current or voltage: 

DPC Voltage Mode

Image 2: DCDC_MODE register in DPC Current mode, 24mA output: DPC Current Mode +24mA out

Image 3: DCDC_MODE register in DPC Current mode, 0mA output

DPC Current Mode 0mA out

Image 4: DCDC_MODE register in DPC Current mode, -24mA output

DPC Current Mode -24mA out

Image 5: Used schematic. VIout_0_CHx and VIsns_0_CHx are connected at the connector:

AOM Circuit

As you can see in image 3, even with no output, the Vdpc- has to deliver more current since the duty cycle of the Vdpc- switching node is greater. When setting the output to -24mA (image 4), the Vdpc- works at first, but as the time goes, current consumption increases, switching node oscillations slowly disappear upto the first peak, then Vdpc- decreases and output current goes to ~21.78mA.

As we ruled out anything else we're stuck with a solution for this problem. The extra current draw has to be directly on the Vdpc- rail, but there is nothing else connected to it except the AD5753 itself. If it was an extra load somewhere on the output, the current output wouldn't work at all. How can we fix this?

Best Regards,

Daniël Kunst

Hardware Engineer @ 3T Electronics

Parents Reply Children
No Data