Post Go back to editing

Questions on SPI of AD5760

Hi all

This is my first time to build a four-layer board with a such high-precision DAC. I made the system and it does not work. I do not know what is wrong.

Could you please kindly help me to check the SPI?

Attached files are the timing diagram captured about CLK VS SDO; CLK VS SYNC*; CLK VS LATCH*.

I am trying to use the gain*2 mode.

The first SPI code is 0x200000, which is the configuration code.

The second SPI code is 0x1fff00, which is to write the DAC register and then the DAC will be latched.

Thank you very much.

Regards

Richie

spi_pics.rar.zip
Parents
  • Hi Estibaliz

    Thanks for your help!!

    Problem solved.

    The timing diagram is correct. When I was trying to test the maximum and minimum value of DAC, I just used 0xffff and 0x0000 and expecting them to have minimum and maximum values.

    However 2's complement is adopted by DAC as a default value. As a result, there is no big difference between these two values. And I though I made s mistake on SPI.

    Now it works fine.

    Thank you very much!

    Regards

    Richie CHEN

Reply
  • Hi Estibaliz

    Thanks for your help!!

    Problem solved.

    The timing diagram is correct. When I was trying to test the maximum and minimum value of DAC, I just used 0xffff and 0x0000 and expecting them to have minimum and maximum values.

    However 2's complement is adopted by DAC as a default value. As a result, there is no big difference between these two values. And I though I made s mistake on SPI.

    Now it works fine.

    Thank you very much!

    Regards

    Richie CHEN

Children
No Data