Post Go back to editing

Reading the AD5696R

I am investigating a problem we are having with reading from the AD5696R. When following the "read operation" procedure, the value returned is nearly always 0x91. I attached a Corelis BusPro-I I2C monitor to the EVAL-AD5696RSDZ and performed a read, and noticed that it did not seem to be following the procedure. When reading from DAC C, the command following the first address byte was 14, not 04 as I understood from the datasheet. Can you explain why I am seeing a different read operation than is described in the datasheet? 

Parents
  • This eval board was ordered directly from Analog last month (order #9396705). When I retrieved the box it arrived in I found a date code of 1751 printed on the box. 

    1. The data sheet should explain how to find the date code.

    2. I don't have access to the boxes the parts used in my application arrived in. Please tell me how to find the date code.

    3. I am still interested in knowing why reads attempted through the Corelis fail.

Reply
  • This eval board was ordered directly from Analog last month (order #9396705). When I retrieved the box it arrived in I found a date code of 1751 printed on the box. 

    1. The data sheet should explain how to find the date code.

    2. I don't have access to the boxes the parts used in my application arrived in. Please tell me how to find the date code.

    3. I am still interested in knowing why reads attempted through the Corelis fail.

Children
No Data