AD5758 have no negative voltage output

Hi,

AD5758 is an new released chip, and now, I use this chip on my board to generate +/-10V voltage.

The circuit as follow:

I got some issue with this chip, could you helps to take a look this.

1

for the Vsense+ pin,

in page 16 of datasheet, "if remove sensing is not being used, short this pin to VIout via a series 1K RES",

in page 16 of datasheet, "if remove sensing of load is not required, connect +Vsense directly to VIout and connect -Vsense directly to AGND".

So, I am confuse whether I should add 1K resistor between VIout and +Vsense pin, please helps to take a look.

2.

My board now can generate 0-10V voltage successfully, but, it can't generate negative voltage.

the VSS is -15V, I have measured it, looks my register configration for ADC is correct also, I have checked it several time.

But, I wonder why I can't get negative voltage. whether I should connect -Vsense to VIout also rather than AGND.

Or, could you helps to analysis the other reason.

Very thanks.

  • Hi, I made a mistake, the follow word is the correct description.

    in page 16 of datasheet, "if remove sensing is not being used, short this pin to VIout via a series 1K RES",

    in page 36 of datasheet, "if remove sensing of load is not required, connect +Vsense directly to VIout and connect -Vsense directly to AGND".

  • +1
    •  Analog Employees 
    on Apr 17, 2019 8:48 AM over 1 year ago

    Hi,

    1. For +VSENSE, it can be directly connected to VIOUT. However, if the application is prone to EMC events we recommend the 1K resistor.

    2. -VSENSE and +VSENSE are used to sense the voltage at the laod and maintain the output voltage on top of the common mode voltage at the load. -VSENSE should be connected to ground if remote sensing is not required as to keep the common mode voltage at 0V. Likewise +VSENSE should be connected to VIOUT if remote sensing is not used.

    Have you written the DAC range correctly? Bits 3:0 in register 0x06 should be 0011 for +/- 10V range??

    Regards,

    Valerie

  • Very sorry, I have got the reason for this.

    you can see the CR49 and U50, 2 DIODES will clamp the negative voltage, it is the reason.

    5758 is an good chip.

    Very thanks for your help.