Post Go back to editing

LTC2309 : ADC analog inputs sinking current!!

I'm using the  ADC LTC2309 to convert analog signals coming from an opam. The analog voltage to measure ranges from 2 to 3.5 V. The signal has very low fluctuations so we can say that it is almost a DC signal.

In one of my experiments I was measuring 2.4V at input 7  and suddenly  the voltage went up by 0.7 V. Hence the measured voltage became 3.1V. I verified this value either by collecting the data via I2C or by measuring directly on  this input.

I thought it was the opam that was giving the wrong signal. Verifying the circuit, it was effectively the ADC pin that was giving the wrong signal.

The connection of components going from the opam output to the ADC input is a 100 Ohm resistor  with a 47pF capacitor from the ADC input  to ground, as recommended in the last figure in the datasheet.

The Vref pin is connected to ground while the Refcomp pin is connected to +5V. I retreive data from the ADC input via I2C using the command F8 that addresses the 7th channel in unipolar mode and seting the ADC in nap mode. Then leaving the ADC in sleep mode, the result is the same.

Observing this, I realize that the ADC input is sinking current which explains the increase of measured voltage at its input.

Another test that I made was removing the 100 Ohm resistor and connecting the output of the opam directly to the ADC input.

The read value was oscillating around  2.55V . Another observation is that the same value applied on input 8 is also present in other pins of the ADC which are not connected.

The question that arises is why the ADC would start sinking current with no apparent reason. ?

I will really appreciate any hint or advices you can provide.

Regards,

Fausto

Parents
  • Hello  mr. Hoover,

    Following up our last discussion, I installed the schottky diodes on the SDA and SCL signals  so the LTC2309 receive the correct levels on SDA and SCL, as can be observed in the snap shots shown below.

    Nevertheless, after an hour or so, the ADC stops responding to the master board. When this happen, I try scannig for connected devices and the ADC no longer appears in the list.

    Do you have an idea what can go wrong?. So far I don't have any other solution to make the circuit work.

    Regards.

    Fausto

Reply
  • Hello  mr. Hoover,

    Following up our last discussion, I installed the schottky diodes on the SDA and SCL signals  so the LTC2309 receive the correct levels on SDA and SCL, as can be observed in the snap shots shown below.

    Nevertheless, after an hour or so, the ADC stops responding to the master board. When this happen, I try scannig for connected devices and the ADC no longer appears in the list.

    Do you have an idea what can go wrong?. So far I don't have any other solution to make the circuit work.

    Regards.

    Fausto

Children
No Data