Post Go back to editing

ad7293

Category: Hardware
Product Number: AD7293

Dear All

We have assembled our PCB with AD7293.

SPI Interface is working with our Xillinx based FPGA and DAC interfaces are also working i.e. voltage is changing on writing the DAC registers, but ADC is not working.

On debugging we have found that voltage at pin 42 REFADC pin is only 80mV while it should have been 1.25V.

Because of this 80mV ADC is being saturated at just 320mV, After 320mV reading is coming same.

Voltage at pin 20,21 VREFIN, VREFOUT is correctly coming to 2.5V.

Kindly find below the schematic for the same.

Kindly Let us know what change do i have to make in order to get correct REFADC-1.25V

Thread Notes

Top Replies

Parents
  • Hi  ,

    I am happy to give you support concerning your query.

    Would it be possible to check if internal ADC_REF is configured correctly? (By default external reference is enabled, so that there are no issues at power-up if an external voltage is being applied to REFADC.)

    Please set high D7 in General Register (Register 0x14) at configuration (Page 0x2) . (See snippet below.)

    Please let me know if REFADC is measuring correct voltage after the register write. 

    Regards,

    Arnost

Reply
  • Hi  ,

    I am happy to give you support concerning your query.

    Would it be possible to check if internal ADC_REF is configured correctly? (By default external reference is enabled, so that there are no issues at power-up if an external voltage is being applied to REFADC.)

    Please set high D7 in General Register (Register 0x14) at configuration (Page 0x2) . (See snippet below.)

    Please let me know if REFADC is measuring correct voltage after the register write. 

    Regards,

    Arnost

Children