AD7768 Diagnostic Mode

Hi, 

I tried to set the Diagnostic Meter Mode by EVAL-AD7768FMCZ + EVAL-SDP-CH1Z.

I set the register 0x56 of the ADC Diagnostic Receive Select Register and 0x57 of the ADC Diagnostic Control Register, but the output data is still input voltage level.

Would you help how to set the diag mode?

Regards,

HM

Parents
  • 0
    •  Analog Employees 
    on Jul 30, 2020 11:23 AM 6 months ago

    Hi HM,

    We would like to know what do you mean by "data is still input voltage level". Have you connected an input on analog input pins?

    The steps to set the diagnostic mode is

    1. Disconnect the analog inputs to the channels which you wish to diagnose.

    2. Enable the pre-charge buffers.

    3. set the bits to 1 on the channels you wish to diagnose in register 0x56.

    4. Set MODE A or B for channels in register 0x03.

    5. Set the input scale (zero, +ve FS or -ve FS) in register 0x57 on the MUX A or B as per the MODE selection.

    Please follow the above steps to use the Diagnostic Meter Mode.

    Regards

    Vikas J

  • Hi, Vikas J-san,

    Thank you for your advice.

    Yes, I tested while connecting an input analog signal, so I took off and retested.

    I set CH0-4 as register 0x56 and +/-FS at register 0x57, but expected DOUT output (+/-VREF=+/-4.096V) wasn't obtained.

    Is this output correct?

    Regard,

    HM

       

  • +1
    •  Analog Employees 
    on Jul 31, 2020 8:19 AM 6 months ago in reply to HM72

    Hi HM,

    Please make sure that inputs are disabled from the front end. Remove R134 and R139 for ch0, R155 and R151 for ch2 and similarly for the rest on EVAL BOARD. 

    Rest everything remains the same. Please try this out. Make sure you select the appropriate Analysis channel as well.

      

    Regards

    Vikas J

Reply Children