Post Go back to editing

problem with the continous mode of AD7738

I cannot read the status and data registers in the continuous mode of AD7738. The single mode is OK. On page 23 of the data sheet in fig.12 the value of the mode register for the continuous mode is wrong. Couldn't find errata for the AD7738.Any idea?

Parents
  • Hi Chris,

    Find attached pictures with the CS line shown on the 3rd
    scope channel. I just replaced the Dout signal from my previous pictures with
    the CS, because anyway the Dout stays high all the time

    And no data is available out of the chip during the read of the
    status and data registers after the Ready line goes low.

    I’m ready to send you more pictures in order to try to help your
    investigation of the problem. Keep in mind that the single mode works fine.

    All problems are with the continuous mode.

    Thanks again . Expecting your expert help.

    BR,

    Peter

    attachments.zip
Reply
  • Hi Chris,

    Find attached pictures with the CS line shown on the 3rd
    scope channel. I just replaced the Dout signal from my previous pictures with
    the CS, because anyway the Dout stays high all the time

    And no data is available out of the chip during the read of the
    status and data registers after the Ready line goes low.

    I’m ready to send you more pictures in order to try to help your
    investigation of the problem. Keep in mind that the single mode works fine.

    All problems are with the continuous mode.

    Thanks again . Expecting your expert help.

    BR,

    Peter

    attachments.zip
Children
No Data