ADAS3023 Evaluation Software

I have some questions/remarks about the ADAS3023 Evaluation Software.

Today I received the EVAL-ADAS3023EDZ board together with EVAL-CED1Z. I made the setup as described. In addition, I grounded the DIG1 Signal (P21) and grounded the COM (P31). I connected a potentiometer to INO_I with a range of -5V to 5V.

Next, I started the ADAS3023 Evaluation Software (Version 2.0). The results look very strange; this is why I start this discussion.

My questions/remarks (please have a look to the screenshot):

  1. In the section “Waveform Analysis”, the minimum value is 32270 which must be a positive voltage since the output format is 16Bit two’s complement. Similar the maximum value 40739 which should result in a negative value. Do I understand something wrong?
  2. The waveforms show a strange behavior. Only every third sample is correct, while IN2 and IN4 show the “missing samples”. It seems that the channels are messed up? (The potentiometer is set to a value of around 1.25Volts)
  3. Unfortunately, the user can’t influence the function of Busy/SDO2 output.

Thank you very much.

Best regards

Chrigu

  • Hi again

    I found a possible solution. First, I’ve forgotten to configure the VIO (P12) to 3.3V. See Evaluation Board User Guide Page7.

    But this didn’t change anything. So I checked the Reset pin and couldn’t measure a reset impulse at startup, this is maybe a bug in the Evaluation Kit!? When applying manually a reset (during idle state, not during conversions), it works fine and the result looks as expected. This solves my question number 2 from above.

    By the way, I think there is a mistake in the ADAS3023 datasheet page 20. The calculation for –FSR is wrong, shouldn’t it be –Vref/PGIA gain instead of –Vref*PGIA gain?

    Best regards

    Chrigu

  • 0
    •  Analog Employees 
    on May 18, 2014 10:40 PM

    HI Chrigu,

    Apolgies for the delayed response. I'll get back to you, I'll try to verfiy and check ypur inquiry.

    Regards,

    Jonathan

  • 0
    •  Analog Employees 
    on May 21, 2014 1:47 AM

    Hi Chrigu,

         Though the output of the ADAS3023 is in twos compliment, but the software outputs the result in straight binary. Please refer to page 14 of the  user guide (UG-515).

         We would like to understand clearly on your 3rd question, can you elaborate further regarding the function of the Busy/SDO2 output?

    Regards,

    Jonathan

  • Hi Jonathan

    Thank you very much for your answer. You are right; I missed to read this line.

    Regarding Busy/SDO2: I use the new version of the evaluation software, and there I can’t find an option to set the Busy/SDO2 in the CFG like it was described in the documentation for the old software (UG515, page 11).

    However, I was able to adapt my custom board so that the ADAS3023 works now. The main mistake was that I connected PD pin directly to ground (since I don’t use the Power-Down Mode). But in my case, the ADAS3023 only works correctly when I (after powering the system) perform a Power Down-Power Up followed by a reset. Maybe this helps somebody.

    Thank you very much and with best regards

    Chrigu

  • 0
    •  Analog Employees 
    on May 21, 2014 6:06 PM

    Hi Chrigu,

         Regarding the -FSR question, I think you're righ that it should be -Vref/PGIA gain. The datasheet will be updated to correct this.

    Regards,

    Jonathan