AD7960 Acquisition Problem.  Missing Codes

Hello Community,

I am trying to evaluate the AD7960. We have designed a dedicated board for testing the device on the ATE system. We have to extract all static and dynamic parameters. The stimulis are a sinus or a ramp generating by AWG 24bits.

But something wrong. Codes is missing. and I don't understand why. I verified all the ATE system. The algorithm to compute the data is certified.

Here is my setup:

E0 to E3: 1001

2.048V to REFIN

Convertion rate: 4MSPS

Any Hints on what is going on would be welcome.

Parents
  • Hello,

    Just to explain the context. We need to evaluate the AD7960 versus temperature. So we need to expose the DUT to the temperature alone. The ADC is mounted on a daughter board with all decoupling as close as possible. Under this daughter board, there is all the capacitors needed.  10µ with 100n for REF and REFIN pins.  And 100n  for every power pins.

    The motherboard is a dedicated board which is connected to Automated Test Equipment (A.T.E.). Through the motherboard you have all the signal conditionning for the analog input, the reference voltages. all decoupling for the supplies.

    The design of all parts is based on the specification of the evaluation board.

Reply
  • Hello,

    Just to explain the context. We need to evaluate the AD7960 versus temperature. So we need to expose the DUT to the temperature alone. The ADC is mounted on a daughter board with all decoupling as close as possible. Under this daughter board, there is all the capacitors needed.  10µ with 100n for REF and REFIN pins.  And 100n  for every power pins.

    The motherboard is a dedicated board which is connected to Automated Test Equipment (A.T.E.). Through the motherboard you have all the signal conditionning for the analog input, the reference voltages. all decoupling for the supplies.

    The design of all parts is based on the specification of the evaluation board.

Children
No Data