A problem about the internal Vref Of AD7667

Hello!

I am now using an AD7667  conversion chip, and I use  the internal reference voltage, the parallel model, but my output has been FF7F, through inspection , I found that the internal reference voltage on the pin of REF is about 0.3V, this means there is something wrong with the internal reference voltage. But my PD, PDREF PDBUF is low, SER/PAR set to high (that is in parallel model), using the model of IMPULSE . 

And after many inspections ,I am sure the circuit ,pin-strap,and the chip of AD7667 are all good.So what's the problem?

Thanks for your help

Parents
  • Tank your help, Tyler.  I want to say that I am a beginner in this field ,and I am not good at English,so you may not quite understand what I have said .It  made you in a trouble.I am deeply sorry for this.

    Then first I also want to say sorry ,because I set  SER/nPAR signal is low,but i write wrong.

    Second ,I measured it again as you said , I am sure the REFBUFIN is sitting 0.00V and the REF is sitting 0.559V . The AVDD ,DVDD and OVDD are at 5V! However , I don't think the chip have problem.Because , I have used three AD7667s,and they all have this problem. My cricuit diagram is as follows:

    Tyler,please help me,thanks.

Reply
  • Tank your help, Tyler.  I want to say that I am a beginner in this field ,and I am not good at English,so you may not quite understand what I have said .It  made you in a trouble.I am deeply sorry for this.

    Then first I also want to say sorry ,because I set  SER/nPAR signal is low,but i write wrong.

    Second ,I measured it again as you said , I am sure the REFBUFIN is sitting 0.00V and the REF is sitting 0.559V . The AVDD ,DVDD and OVDD are at 5V! However , I don't think the chip have problem.Because , I have used three AD7667s,and they all have this problem. My cricuit diagram is as follows:

    Tyler,please help me,thanks.

Children
No Data