AD760x RESET glitches

Hi,

there are reports of AD760x devices suddenly returning only zeros due to glitches on the RESET line, like here or here, the latter unfortunately solved through a private message. We seem to have a similar problem.

Are there any solutions available except for performing a reset before each conversion?

Regards,

rehfi

Parents
  • Hi Jonathan,

    We are using the AD7609 on multiple data acquisition boards, with 2 to 4 devices doing simultaneous sampling. The board where we actually saw the problem is an isolated variant, with a Si8455 digital isolator driving the RESET line. The customer uses this board in a industrial PC for a hardware simulation application, but I don't know if it is used in a EMI susceptible environment.

    What about that 10.7 ns critical timing mentioned here?

    jcolao wrote:

    I will share this with my colleague and there are ways for a possible protection circuit.

    I would like to learn more about it...

    Regards,

    rehfi

Reply
  • Hi Jonathan,

    We are using the AD7609 on multiple data acquisition boards, with 2 to 4 devices doing simultaneous sampling. The board where we actually saw the problem is an isolated variant, with a Si8455 digital isolator driving the RESET line. The customer uses this board in a industrial PC for a hardware simulation application, but I don't know if it is used in a EMI susceptible environment.

    What about that 10.7 ns critical timing mentioned here?

    jcolao wrote:

    I will share this with my colleague and there are ways for a possible protection circuit.

    I would like to learn more about it...

    Regards,

    rehfi

Children
No Data