Post Go back to editing

FPGA design files for D2390A-A evaluation board and Arrow/Terasic SoCkit Cyclone V FPGA evaluation board

I am using the DC2390A-A evaluation board for the LTC2500-32 ADC with the Arrow/Terasic SoCkit Cyclone V FPGA evaluation board.  I cannot find the design files for the Arrow/Terasic SoCkit evaluation board for use with the DC2390A-A.  I am in need of the design files to program the Cyclone V FPGA of the SoCkit evaluation board so that I can evaluate the LTC2500-32 on the DC2390A-A evaluation board.

I can't even find the pinout information for the DC2390A-A evaluation board!  So at this point, the DC2390A-A evaluation board is useless.

Thank you for any assistance with this issue!

  • Hi, Hypelnst and ghoover. I have encountered some similar problems.  

    When I booted the SoCkit board using Linear Technology's SD card image, I can see the assigned IP address will appear in the LCD screen using the software of Putty connected by micro_USB. I thought I was close to success.

    Regrettably, when I installed LinearLab Tools follow the directions in the DC2390 demo Manual and  mounted the DC2390 to the SoCkit board via the HSMC connector, I can't find the IP address in LCD screen  after power up the SoCkit board.  In additon, when I run "", I receive the following error message: ImportError: No module named llt.utils.save_for_pscope

    Thank you so much!


  • I got some progress, however, when  I run "", I receive the following error message:

    error: [Errno 10061] 

    And I run "" encounter the same problem. I'm confused, I don't understand the meaning of this error.

    PS: The script "" executes properly.


  • Here is what I turned up on a Google search of that error>

    [Errno 10061] No connection could be made because the target machine actively refused it

    My best guess is that the DC2390 is somehow preventing the SoCkit from booting.

    Try disconnecting the DC2390 board and see if the SoCkit board will display its IP address. If it does, that suggests the DC2390 is damaged. If the SoCkit board still doesn't display its IP address, that suggests the SoCkit board is damaged. If the SoCkit board does display its IP address, use an external 12V supply at Vin and GND to power the DC2390. (Do not connect it back to the SoCkit board yet). Measure VREF1, VREF2, +5V, -5V, +2.5V, V+ and V- terminals.

    Test Point
























    If everything looks good, then remove power from DC2390, reconnect the DC2390 to the SoCkit board and then apply power to the SoCkit board. After a few moments the SoCkit board should display its IP address. 

  • Yup, that shouldn't happen. I notice that you don't have the DC2390 screwed down to the SoCkit board, with 5mm standoffs. The HSMC connector is not designed to provide a robust physical connection, it needs to be secured. Not that this would directly cause a problem, but consider the case where the 3.3V connections are momentarily broken, it could reset the FPGA. (This would be intermittent, not necessarily occur every time.)

    Do post the results of measuring the testpoint voltages.


  • Please note that there is a jumper on the SoCKit board (JP2) to set the I/O voltage of the HSMC.  This must be set to 3.3V for the DC2390A-A.  Is the setting correct in this case?

  • Thanks for your response, I have measured carefully the testpoint voltages of DC2390A-A, everything looks good. And I have tighten mounting screws using 5mm standoffs between boards. The jumper(JP2) is set to 3.3V.

    When I  power up the SoCkit board again, the SoCkit board display its IP address, but  the FPGA_CONF_D LED don't illuminate.  When I run "", I receive the same error message:

    File "C:\Users\guofengzhao\Anaconda2\lib\", line 228, in meth
    return getattr(self._sock,name)(*args)

    error: [Errno 10061]

  • Do you see something like this when you start DC2390_hello_world?

    runfile('C:/Projects/linearlabtools_bitbucket/linear_lab_tools/python/llt/app_examples/ltc2500_family/', args='', wdir='C:/Projects/linearlabtools_bitbucket/linear_lab_tools/python/llt/app_examples/ltc2500_family')

    If the args= is not what the SoCkit display shows for an IP address, change the else portion of line 60 to match the IP address shown in the SoCkit display.

    Have you attempted step 11 in the DC2390A demo manual?

  • Good advice - step 11 is critical, and if the symlink was not set up properly, it might be the explanation. You should be able to program the FPGA from the command line with the program_fpga script, you can give either the symlink as the argument, or any of the rbf files directly.

Reply Children
No Data