Post Go back to editing

Problem with PLL Locked Option in ACE Software for AD9122.

         thank you for your last help regarding ACE software, that solved my connection issue. But now there is problem with PLL Locked option in ACE software.
Inline image 2
it should have glow after the successful connection made. but it didn't.
i have given input to boards as below:
1)  Power Supply P5(+5V), P6(GND)
2) Signal Source J1(CLOCK IN), Set source to 500MHz, 2dBm output
3) PC  USB  Cable XP2
4) DSO at   J3 (DAC1_P) or J8 (DAC2_P)
5) Data Bits D0-D15 , Frame signal and DAC_CLK_IN from FPGA.
 
the software setting that i have done is given below:
Inline image 3
Inline image 4
 
please help me with it.
 
 

Thanks and Regards

Imran
 
Parents
  • Hello MicheleV

    Thanks

    This time  I got some output but it is not look like sinewave. I also tried to generate raw data using binary and two's complement. 

     I don't understand this statement "If the data still doesn't look right, instead send DC data to the part by sending a value of 0x0000 to the Q DAC and 0x7FFF to the I DAC (two's complement setting in the wizard please)." please clarify.

    I changed the jumpers JP4/JP5 and JP6/JP17 jumpers to be the outer pads.

    1) without giving input to DAC i got sine wave

    2)with giving sinewave in binary i got this

    DCI frequency at probe A2 or B2 on the P1 connector is 125MHz

     

    and at R26 near the DAC i got 500MHz

     

    at 500MHz DAC clk , 1) what should be the data rate for DAC input?

                                         2) how to configure ACE software?

     

    Thanks and Regards

    Imran

Reply
  • Hello MicheleV

    Thanks

    This time  I got some output but it is not look like sinewave. I also tried to generate raw data using binary and two's complement. 

     I don't understand this statement "If the data still doesn't look right, instead send DC data to the part by sending a value of 0x0000 to the Q DAC and 0x7FFF to the I DAC (two's complement setting in the wizard please)." please clarify.

    I changed the jumpers JP4/JP5 and JP6/JP17 jumpers to be the outer pads.

    1) without giving input to DAC i got sine wave

    2)with giving sinewave in binary i got this

    DCI frequency at probe A2 or B2 on the P1 connector is 125MHz

     

    and at R26 near the DAC i got 500MHz

     

    at 500MHz DAC clk , 1) what should be the data rate for DAC input?

                                         2) how to configure ACE software?

     

    Thanks and Regards

    Imran

Children
No Data