Post Go back to editing

AD9674 Problems with Trigger

Hi there,

 

Unfortunately we need help with the commissioning of the AD9674.

We program the device via SPI as described in the data sheet. We use the chip grade of 80 MHz and the 12 bit operation without RF decimator and have adapted the places in the example. In the following the register description is described. Left is the address and right is the corresponding value.

                  //                adr         val

                                   0x000,      0x3c,                  

                                   0x002,      0x20,                  

                                   0x0ff,        0x01,                  

                                   0x004,      0x0f,                  

                                   0x005,      0x3f,                  

                                   0x113,      0x00,      

                                   0x011,      0x06,      

                                   0xf00,       0xff,                  

                                   0xf01,       0x7f,                  

                                   0xf02,       0x00,      

                                   0xf03,       0x80,                  

                                   0x10c,      0x00,                  

                                   0x014,      0x00,                  

                                   0x008,      0x00,                  

                                   0x021,      0x00,

                                   0x199,      0x80,            

                                   0x19B,      0x50,                  

                                   0x188,      0x01,

                                   0x18b,      0x27,            

                                   0x18c,      0x72,                  

                                   0x182,      0x82,

                                   0x10c,      0x20,

                                   0x00f,       0x18,                  

                                   0x02b,      0x40,

But the AD9674 has a zero line on all 8 outputs. The SPI inputs of the ADC are controlled and
are controlled correctly.

What could be possible reasons for this? Thanks for your help.

Parents
  • Hi SeBaHu,

    The SPI register writes seem to be correct. Do you use the TX_TRIG pin? Is it held low or high? Refer to Figure 52 for the digital output state. If the digital section is not running then the outputs will be zeros. 

    Can you also try to enable a digital output test mode using register 0x00D and check the output?

    Regards

    Ashraf

Reply
  • Hi SeBaHu,

    The SPI register writes seem to be correct. Do you use the TX_TRIG pin? Is it held low or high? Refer to Figure 52 for the digital output state. If the digital section is not running then the outputs will be zeros. 

    Can you also try to enable a digital output test mode using register 0x00D and check the output?

    Regards

    Ashraf

Children