Post Go back to editing

Why AD9864 output is noise when input IF signal is -90dBm

Our product is using AD9864, by out test, when the input IF signal with level of -90dBm directly into AD9864, and the DSP capture AD9864 SSI output IQ data then draw it with Matlab, the data is almost noise, we can't see valid signal. For -70dBm input or -30dBm input, the IQ data looks ok.

So, what's the possible reason for my problem, hardware or AD9864 configuration issue? Could anyone help me? Also I want to know what's the smallest input level that AD9864 can accept.

Here is my AD9864 register setting. And my IF input freq is 73.35MHz, LO freq is 71.1MHz.

Parents
  • Hello,

    1) Updated datasheet is on website................ http://www.analog.com/media/en/technical-documentation/data-sheets/AD6676.pdf.

    2) Based on you decimation factor of 900 and SSI frame length of 48...........you should be fine with a clock rate of 1.5 MHz to capture all 48-bits within a frame.

    3) The IQ data looks odd for the -30 dBm (and -90 dBm case) since the I and Q waveforms have entirely different envelope characteristics (see plots below).  I would advise using simple CW tone that is 1 KHz offset (i.e no modulation) to simply debug.   Make sure that the AGC is disabled (0x06=0x0) set CW tone to around -37 dbm level into the AD9864 IF input (i.e. about -8 dBFS for a nominal IF clip point of -31 dBm) such that ADC is several dB below its saturation point.   Expectation is that one should see 1 KHz CW tone on both the I and Q output that are 90 degrees out of phase.

    Regards.

    attachments.zip
Reply
  • Hello,

    1) Updated datasheet is on website................ http://www.analog.com/media/en/technical-documentation/data-sheets/AD6676.pdf.

    2) Based on you decimation factor of 900 and SSI frame length of 48...........you should be fine with a clock rate of 1.5 MHz to capture all 48-bits within a frame.

    3) The IQ data looks odd for the -30 dBm (and -90 dBm case) since the I and Q waveforms have entirely different envelope characteristics (see plots below).  I would advise using simple CW tone that is 1 KHz offset (i.e no modulation) to simply debug.   Make sure that the AGC is disabled (0x06=0x0) set CW tone to around -37 dbm level into the AD9864 IF input (i.e. about -8 dBFS for a nominal IF clip point of -31 dBm) such that ADC is several dB below its saturation point.   Expectation is that one should see 1 KHz CW tone on both the I and Q output that are 90 degrees out of phase.

    Regards.

    attachments.zip
Children
No Data