AD9628-125 captured data spectrum have too much spur when higher input level

hi, Ms/Mr

we use AD9628-125 for data capturing, and met following issue: the output data spectrum have too much spur when ADC input level increased

first, we disable input, and got clean ADC output spectrum, then, enable -16dBm CW input, with Agilent Signal Generator, frequency is 19MHz, sampling rate is 122.5MHz,  the out put spectrm have some spur but seems OK, finally, we increase input level to be 0dBm, which equal ~-16dBFS, we found lots of spur pop up.

in another test, we use 2.5MHz or 10MHz LTE input, ~157MHz freqency and 122.5M sampling rate, we found the output spectrum's noise floor increase with input level, as shown in attached snapshot. there is some ACP due to external amplifier, but you can see major noise from ADC

can anybody help check any possible solution to resove this issue? or any trial we can take to improve?

thanks!

Parents
  • Hi JJF,

    Thank you for using the AD9628.

    To be sure the ADC has powered up and initialized properly would you please do a Digital Reset (after the sample clock is stable)?

    SPI_Write (0x08, 0x03); # Start Digital Reset
    SPI_Write (0x08, 0x00); # Complete Digital Reset and return to normal operation

    Do the spectrums change appearance after this?

    Thank you.

    Doug

Reply
  • Hi JJF,

    Thank you for using the AD9628.

    To be sure the ADC has powered up and initialized properly would you please do a Digital Reset (after the sample clock is stable)?

    SPI_Write (0x08, 0x03); # Start Digital Reset
    SPI_Write (0x08, 0x00); # Complete Digital Reset and return to normal operation

    Do the spectrums change appearance after this?

    Thank you.

    Doug

Children