AD2S1210开发板解码多摩川旋变,方波输出

各位前辈好!

我购买了一块AD2S1210的评估板和转接板,用来解码多摩川的旋变。如下图所示,旋变还没有装到电机上,但是足够读取原副边线圈的正余弦波形。

现在通过上位机设置,激励正弦信号是10kHz,fault的设置我按照默认值弄的,没有改动,模拟编码器输出是10位,精度10位。

在这种情况下会报DOS和跟踪误差的错,但是能观测到解码器有输出。我看到论坛里有人提问也说过报DOS LOT错误但也能得到正确的解码,这个检测错误的电路和解码电路是分开的,所以我暂时没有管这两个错。

示波器上三个正弦信号,激励信号(中间)幅值约为-4.8V~4V. 正余弦信号同频,幅值在+/-1.5V和+/-2V.

但是问题出现在解码后的位置波形,如下图所示。我用手转动旋变转子,发现在机械角360内出现了四次90°的方波,并没有出现三角波。由于是缓慢旋转的,转速很低,所以底下的速度波形是在0上下波动。求教有没有有经验的前辈可以指导一下,解码出来的波形为什么会出现方波,这个问题跟我没有设置DOS LOS LOT的阈值有关吗(我改过不同值,依然没有解决问题)?

谢谢谢谢!!!

  • 0
    •  Analog Employees 
    on Apr 6, 2021 9:40 AM 8 days ago

    SIN/COS信号差分输入2.2~4V的最大峰峰值都可以,检查下信号和连接线对不对,故障寄存器跟解码没有关系

  • 谢谢您的回复!我又按照您的提示重新接线,两个激励线(黄白-红白),四个正余弦线(红-黑,蓝-黄),测试之后得到的波形如下图所示。因为是用手随意转动轴的,包络波形看起来不是规范的正余弦信号,放大之后的正余弦信号如图2所示。包络线的最大值Vpp在+/- 2.8V. 求问旋变这样的输出是否正常。

    在这样的正余弦信号输入情况下,上位机的位置和转速解码如下所示。位置依然是0-90度之间的方波,转速接近零但是毛刺非常严重。我将编码器寄存器的设置反复调试,改成360度或者44°相位角、使能滞环或者不使能、编码器位置精度改成10位14位16等,依然没有办法得到三角波波形。

    求问在这种情况下是认为我的旋变输出的正余弦信号有问题,还是AD2S1210上位机的参数配置不对?万分感谢您的回复!

  • 另外请教您一个跟AD板子无关的问题,就是旋变输出信号是以下的波形,是否是不正常的,这种波形会导致板子无法正确解码?

    旋变1,多摩川smartsyn系列,变压比理论值0.5+/-0.05 (实际测量变压比约在0.5,如下所示)

    激励5vsine信号,由AD板子EXC口输出;旋变的响应输出是包络幅值最大2.8V的正余弦信号。

    旋变2,多摩川singlsyn系列,变压比理论值0.286+/-0.1 (实际测量变压比约在0.13,偏小,如下图所示)

     激励5vsine信号,由AD板子EXC口输出;旋变的响应输出是包络幅值最大0.65V的正余弦信号。

    目前拿这两个旋变进行测试,都无法正确解码。旋变1的波形更接近我在论坛里看到的其他up主po的波形,旋变2波形我认为有点不正常,但是找不出原因,因为旋变本质就是两个绕组,除了短路断路老化,我实在想不出来还有什么问题能够导致变压比远小于理论值。

    不知道在这种情况下是板子的设置错了还是旋变输出的信号有问题。请有经验的工程师帮忙分析一下,谢谢谢谢!

  • 工程师您好!确实是接线问题!现在正余弦响应波形是对的,但是幅值达不到2.2V. 包络的幅值最高在+/-1.5V. 

    目前使用万用表测量表明激励正弦波有效值在3.95V,旋变的变压比0.286,故副边正余弦响应波形幅值达不到2.2V. 

    在这种情况下解码出来的位置波形仍然是0-90°之间的方波。请问我需要调节评估板子上的R1、R2两个电阻来提高激励正弦波的幅值吗?还是说在目前这种情况下,我对开发板上位机的参数配置有问题?您可以指教一下吗?谢谢!