Post Go back to editing

用AD623搭建了一个电桥信号放大的模块,但是输出不稳定

如图所示,我将电桥的两路输入信号输入,输出一个放大信号在经OP07进行放大,实际PCB焊好调试时发现,总的输出会有一个漂移,而且这个漂移很诡异,有时候会缓慢的增大,而且漂移的时间会很长,几个小时后都还在变化,但速度已经非常的慢,有时候会缓慢的减小,总之就是不能稳定下来,对于放大的信号是IN+和IN-都是2.5V左右,两个之间的差值是零点几个毫伏,输出信号的值主要在mv级跳变,但是由于其总是朝着一个方向漂移,所以一段时间后的累积变化会相对较大,所以不知道大家有没有什么解决方法呢?

  • 对了,有一个问题忘了提了,AD623的单电源供电数据手册上写的是3V到12V,双电源是正负2.5V到正负6V,可是我这个图我当时直接给供的正负12V的电源,不知道这个是不是造成上面问题的原因

  • 如果直接供给AD623+/-12V的电源的话,已经超出手册规定的最大额定值了,可能造成芯片损坏,那么手册里标注的性能规格也没有办法保证。

  • 您好,我一共调试了两块电路板,两块原理图都是一模一样的,唯一的区别在于,一块用的是AD622,一块用的是AD623,之前说的AD623的电源电压是超过极限值的,但是AD622并没有超过极限值正负18V,而且之前说的输出不稳定的情况同样出现在AD622上,主要的表现有两个,第一个是偶尔会出现当天第一次上电的时候,他的输出值偏移的比较快,我用12位的ADC来采样,会在一个小时之内偏移20个左右的LSB,但是之后就比较稳定了,第二个就是正常情况下,在达到稳定的情况下,关闭电源,一段时间后再打开电源,大部分实验结果都会在半个小时之内慢慢偏移5个左右的LSB,就会达到基本稳定,后面的变化就会十分缓慢。关于上述的情况,想请问您,我该如何解决这些偏移呢?实际的电路上面已给出,关于供电电源用的是电源模块A2412S转开关电源的24V为正负12V给AD622的。希望能您能帮助我,这个问题已困扰了我很长时间。

  • 我的建议是,首先确定漂移的根源位置。

    你可以将图中的AD622输入端短接接地,保持OP07和后续采集系统不变,再次进行实验。如果漂移消失了,就说明是传感器的问题。如果仍发生漂移,就继续将OP07的输入端短接接地,如果仍发生,就将12位ADC输入短接接地。这样做,持续下去,总有稳定的时刻。就找到漂移位置了。

    确定了漂移位置,我建议你考虑温度带来的影响。从现象看,特别像温度的影响。

    另外,你的漂移量大约在1/200~1/800。AD622、OP07本身一般不会有如此大的温漂。重点可以考虑传感器。

    反正,将故障位置缩小到极致,是破解的关键。

  • 您好,看到您的回复已经好几天了,十分感谢您的指导,我这几天一直在按照您的要求进行测试,关于漂移的根源位置,目前初步可以定为传感器的原因,因为我将运放的输入接地后测试的结果没有漂移,而且基本没有跳动,然后我又将前端电桥的输入接入后数据有漂移存在,由于测试的次数比较少,我打算之后继续测试2天左右,然后在看看结果。

    还有就是,您是《你好,放大器》的作者,杨建国教授吧,,我还有一个问题请教您,就是我的传感器部分其实就是一个电桥,也就是几个电阻,我觉得漂移是不是来自于两个方面,一个是电阻本身的升温导致的阻值的改变,还有一个是电源自身的细小纹波,那么,对于这些漂移我该如何去抑制呢?就是说在电桥输出和运放输入之间,我该怎样通过外围电路去消除这种漂移呢?等待您的解答