EVAL-CN0428-EBZ

Hello all,

I have an EVAL-CN0428-EBZ board on an EVAL-M355-ARDZ-INT and an EVAL-ADICUP3029.

With the help of the .hex-file I was also able to perform first measurements. Afterwards, I wanted to load my own applications onto the Eval board with the help of the IAR Embedded Workbench. Based on this document: https://wiki.analog.com/resources/eval/user-guides/circuits-from-the-lab/cn0428-cn0429-programming-with-custom-firmware#downloading_and_running_the_aducm355_installer I used the on-board debugger. Flashing worked and I could also enter "help" in the terminal, but that was it. No commands are displayed and I cannot perform any measurements.

After that, I tried to load the .hex file onto the Eval board again. This also worked and no fail.txt is displayed, but again I can neither carry out measurements nor is any output displayed in the terminal.

Does anyone have an idea what the problem could be?

Many thanks for the help

Parents
  • 0
    •  Analog Employees 
    on May 5, 2021 7:56 PM

    Hello,

    A couple things I would check first. If you download and debug with IAR, based on the settings shown in the wiki, it will set a break point when it gets to the main function. From that point, the code is paused and you have to hit run before it can respond to commands.

    For the hex file method, the code doesn't start running immediately after the flash is programmed. The microcontroller needs a reset first. Did you try unplugging and replugging the USB to start the code after programming with the hex file? Maybe worth mentioning that the reset button on EVAL-ADICUP3029 doesn't affect the ADuCM355 on the sensor board so you have to hard reset it by unplugging the USB cable.

    Thanks,
    Scott

  • Hello Scott,

    thank you for the notes. Unfortunately it still does not work.

    1. Programming and debugging via IAR
    Even after downloading and pressing run, I get no output on the inputs, like help, in the terminal. I have made a screenshot of the terminal and the workspace. I use Putty as a terminal with a baud rate of 115200, 8 data bits and 1 stop bit.
    I have taken the example from the ADuCM355 installer version V2.2.039.

    When I click on run the orange led flashes, as soon as I enter something in the terminal it also flashes.

    2. Programming mbed
    I have also done the hard reset, but again I get no output from the terminal.

    Thanks

  • 0
    •  Analog Employees 
    on May 11, 2021 8:34 PM in reply to Maxem

    Hello,

    Could you verify with a DMM that the traces are cut properly and not still connected?

    If you press reset on the EVAL-ADICUP3029, does anything print out? Startup text printout wouldn't be affected by the ADuCM355 firmware at all, only the ADuCM3029 firmware and correct COM port and PuTTY setup.

    If not, check the serial port and PuTTY settings.

    If that's all correct and there's still no printout, I would suggest reprogramming the EVAL-ADICUP3029 in case that firmware got corrupted or overwritten. This would require plugging the ribbon cable from P12 on ADICUP3029 to P14 on ADICUP3029 instead of being plugged into the interposer, and drag the hex file from https://github.com/analogdevicesinc/EVAL-ADICUP3029/blob/master/projects/ADuCM3029_demo_cn0428_cn0429/Release/ADuCM3029_demo_cn0428_cn0429.hex like you would've done originally according to the main wiki user guide instructions.

    Thanks,
    Scott

  • Hello,

    the connections have been correctly disconnected and the DMM has also confirmed this. Unfortunately, pressing the reset button did not help either.

    But reprogramming helped and now everything works again.

    If I now want to download my own code via the IAR Workbench, do I have to connect P12 and P14 again or P12 and P10 of the interposer?

    Thanks a lot for the help and tips,

    Max

Reply
  • Hello,

    the connections have been correctly disconnected and the DMM has also confirmed this. Unfortunately, pressing the reset button did not help either.

    But reprogramming helped and now everything works again.

    If I now want to download my own code via the IAR Workbench, do I have to connect P12 and P14 again or P12 and P10 of the interposer?

    Thanks a lot for the help and tips,

    Max

Children
  • 0
    •  Analog Employees 
    on May 26, 2021 1:31 PM in reply to Maxem

    Hi Max,

    Sorry for the delay. For programming the ADuCM355 on the CN0428 sensor interface boards, the SWD signals (from P12 on the ADICUP3029) need to be connected to the interposer P10. Then the switch S1 on the interposer board should be set to the site of the CN0428 board you want to program. This is also shown on the programming custom firmware wiki with a bit more detail as you shared earlier.

    Let me know if there's anything else I can do to help.

    Best regards,
    Scott