Post Go back to editing

EVAL-CN0359-EB1Z polling over RS485 not working

Hello,

I am trying to automate data logging on a CN0359 eval board and I cannot get the poll command to work.

The command I have been trying to use "1 poll\n"

Some of the things I have tried:

  • I have tried multiple different USB to RS485 converters
    • One which has worked with other devices: USBG-COMi-M
    • These are capable of outputting at the baud rates I have tested
    • I have tried wiring them backwards, B->A  A->B, just for good measure
  • I have tried using Putty, TeraTerm, and Python
  • I have tried setting my board to different RS485 addresses and baud rates
  • I have tried sending 2 spaces before my command, like in the user guide. ex "  1 poll\n"
  • I have tried using other commands. ex "1 setvolt 2.5" and they do not update values on the board.
  • I have tried re-flashing the board with the newest firmware
  • I have tried sending commands from an arduino through a serial to RS485 converter shield, which I know works with other devices.

Throughout all of this I have never gotten any response.

All other functions of the board are working correctly.

Any ideas would be greatly appreciated.