EVAL-M355-ARDZ-INT headers installed incorrectly

Hello Michal,

Today I tried to assemble the second unit of our gas analyzer prototype. I used exactly the same hardware and to my surprise it didn't work, I couldn't even turn it on. After a review and finding nothing missing, disconnect the sensors with the CN0429 boards, connect the power and the system start normally. If I reconnected the sensors, the system would shut down as if I suffered some kind of electrical problem (short circuit).

Looking carefully at the EVAL-M355-ARDZ-INT board in prototype 1 and prototype 2, I realize that in the second all the connectors were welded upside down (see photo). The board that works correctly says to be assembled in the USA while the other does not indicate where it was assembled. The lousy production quality control system that Analog Device is having is inconceivable.

I urgently need a way to return the defective boards EVAL-M355-ARDZ-INT and EVAL-CN0429. I really feel disappointed by the situation

Alain



Split from a previous conversation because its a new question with a different title
[edited by: Brandon at 3:16 PM (GMT 0) on 23 Sep 2019]
Parents
  • 0
    •  Analog Employees 
    on Sep 23, 2019 3:20 PM over 1 year ago

    Hi Alain,

    Sorry for this trouble, but can you provide me some information please.

    Which board in the image you sent has the connectors populated in the correct orientation?  Can you also please tell me where you purchased your EVAL-M355-ARDZ-INT?  I'm going to try and help you get another board as fast as possible but I need some information first.

    Cheers,

    Brandon

  • Hi Brandon,

    The board with the correct layout is the one to the right. That is, with the channel selection switch placed on the left, the connector guides must look down.

    We buy all the components through Mouser.

    After an inspection of the 16 EVAL-M355-ARDZ-INT that we acquired, 3 are in that situation.

    The biggest problem is the time ADI have made me lose in the diagnosis of why the system was not working properly, first because of the CN0429 and now this. I had no answer to how to place a storage element to the system to have a long-term log. As you can see they have been a high number of setbacks

    Alain

  • +1
    •  Analog Employees 
    on Sep 23, 2019 5:22 PM over 1 year ago in reply to alainmlaguardia

    Hi Alain, 

    There was a small batch of inventory that hit the shelves which exhibited this issue for connectors that were incorrectly assembled during manufacturing.(effectively put in backwards)  And the likely scenario is that you were able to purchase these boards before the ADI recall went into effect to fix the issue.

    Given that you bought these through an authorized distribution, what you'll need to do is get in touch with Mouser directly (I recommend calling directly with a phone, don't use text or email).  Let them know that you spoke with Analog Devices through the EngineerZone forums and you need to exchange the 3 wrong boards with 3 brand new boards that don't have any connector issues.  Tell them to send the 3 wrongly populated boards back to ADI, and we will have the connectors fixed on them.  You can reference this conversation as well when speaking with Mouser.

    Again apologizes for the inconvenience.

    Cheers,

    Brandon 

Reply
  • +1
    •  Analog Employees 
    on Sep 23, 2019 5:22 PM over 1 year ago in reply to alainmlaguardia

    Hi Alain, 

    There was a small batch of inventory that hit the shelves which exhibited this issue for connectors that were incorrectly assembled during manufacturing.(effectively put in backwards)  And the likely scenario is that you were able to purchase these boards before the ADI recall went into effect to fix the issue.

    Given that you bought these through an authorized distribution, what you'll need to do is get in touch with Mouser directly (I recommend calling directly with a phone, don't use text or email).  Let them know that you spoke with Analog Devices through the EngineerZone forums and you need to exchange the 3 wrong boards with 3 brand new boards that don't have any connector issues.  Tell them to send the 3 wrongly populated boards back to ADI, and we will have the connectors fixed on them.  You can reference this conversation as well when speaking with Mouser.

    Again apologizes for the inconvenience.

    Cheers,

    Brandon 

Children