CN-0409 turbidity sensor - No serial output

Hi,

I recently got the CN-0409 turbidity sensor kit.

I have flashed the software correctly using Debug port. I can the see the code executing to and past the Serial output line.

Then, I connected to my terminal using the settings  in the screenshot through the USB port.

  

It connects, but there is no communication. 

I have checked another serial device on the computer and it works, but not this ADI board.

Please help with this.

Thanks

Parents
  • Hi,

    There are two possibilities that I can think of which are the likely causes.

    1. You have the switch matrix setup incorrectly on the ADICUP360.  Can you tell me which USB port you are using to go back to the computer?  Is it the DEBUG USB or the USER USB?  Can you please tell me exactly how you have the switches (S1-S4) and Jumpers (J1-J5) setup?  A picture here would be fine as well.
    2. You have semihosting enabled on your IDE.  Assuming you are using CrossCore Embedded Studios (which is our supported IDE) follow these instructions here to ensure that semihosting is turned off(https://wiki.analog.com/resources/eval/user-guides/eval-adicup360/tools/cces_user_guide#disablingenabling_semihosting).  Once turned off, please build/compile/download the code again to the ADICUP360.  Then try to see if you can get the code to output on the serial terminal.

    Cheers,

    Brandon

Reply
  • Hi,

    There are two possibilities that I can think of which are the likely causes.

    1. You have the switch matrix setup incorrectly on the ADICUP360.  Can you tell me which USB port you are using to go back to the computer?  Is it the DEBUG USB or the USER USB?  Can you please tell me exactly how you have the switches (S1-S4) and Jumpers (J1-J5) setup?  A picture here would be fine as well.
    2. You have semihosting enabled on your IDE.  Assuming you are using CrossCore Embedded Studios (which is our supported IDE) follow these instructions here to ensure that semihosting is turned off(https://wiki.analog.com/resources/eval/user-guides/eval-adicup360/tools/cces_user_guide#disablingenabling_semihosting).  Once turned off, please build/compile/download the code again to the ADICUP360.  Then try to see if you can get the code to output on the serial terminal.

    Cheers,

    Brandon

Children