CN0359: Float of signal from Instrumentation Amplifier

We have set up EVAL-CN0359 and have the following problem. 
We are measuring the voltage from J5 pins 2 or 3.
These feed AD8253.
We see the expected distorted square wave on the scope but it is floating up and down between the rails.
Page 18 of the datasheet for AD8253 possibly implies that the inputs are not stabilized by a bias current path to ground in the CN0359 layout.
See also fig. 6 of your article by Kitchin concerning "Common Problems When Designing Amplifier Circuits".

Any advice here? T
hanks--Fritz
Parents
  • Hi Fritz,

    Is there a conductivity probe connected on J5? If there is, can you send me the product page for it? Also, can you send a snapshot from the signal captured on your scope? I'll try to recreate the cause of the floating effect you're seeing

    It is correct that a current return path is needed, especially for AC coupled signals. The CN0359 does not use AC-coupling on the signal. The current driving the conductivity probe enters through one of the electrodes (the one connected to pin 1 of J5 and/or pin 2 if it is a 2-electrode probe) and has its return path via the trans-impedance amplifier U19.

    Regards,

    Nikko

Reply
  • Hi Fritz,

    Is there a conductivity probe connected on J5? If there is, can you send me the product page for it? Also, can you send a snapshot from the signal captured on your scope? I'll try to recreate the cause of the floating effect you're seeing

    It is correct that a current return path is needed, especially for AC coupled signals. The CN0359 does not use AC-coupling on the signal. The current driving the conductivity probe enters through one of the electrodes (the one connected to pin 1 of J5 and/or pin 2 if it is a 2-electrode probe) and has its return path via the trans-impedance amplifier U19.

    Regards,

    Nikko

Children