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1. Introduction 
This evaluation note is intended to provide application support for the ADV7630 evaluation board. It also provides 
details on the set up and manual configuration of the evaluation board. Software drivers are available for this 
evaluation board - a separate user guide is available for these software drivers.  This note applies to board 
revisions B. 

2. Evaluation Kit 
The ADV7630 evaluation board kit should consist of the following: 

1. ADV7630 Evaluation Board 

2. 7.5V DC power supply module 

3. USB cable 

3. Initial Hardware Configuration 
The ADV7630 evaluation board is a standalone evaluation platform used to demonstrate all features of the 
ADV7630. To assemble the platform, connect the female connector of the 7.5V DC power supply module supplied 
with the evaluation kit to the motherboard power connector, J10. To turn the evaluation platform on, flick the 
power switch (S1) to position “ON”. The green power LED (D15) should light. Once the board is powered up, 
connect the USB cable supplied with the evaluation kit to USB connector, J12. The hardware platform is ready to 
use. In order to use it DVP Eval software must be installed as per section  3.1 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1. Evaluation board 
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3.1 DVP Eval Installation 

1. DVP Eval software can be downloaded from FTP site. Refer to Appendix 4 – Downloading from FTP section. 

2. Run ADI-DVP-Installer-1.5.3.exe file 

3. Review the license agreement and click “I Agree” if the terms of the agreement are acceptable 

 

Figure 2 – License Agreement 

4. Select the desired access links – desktop shortcut and/or start menu shortcut (see Figure 3) 

 

Figure 3 - Installation Options 

5. Press “Next>” 

6. Accept installation folder (see Figure 4; the default folder is User’s “My documentation” folder) and press 
install.  
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Figure 4 - Installation Folder 

7. Depending on your PC configuration the following window may pop up. If so Select ‘This program installed 
correctly” 

 

Figure 5.System window 

8. Shortcuts to the program are placed in the start menu and on the Desktop (see Figure 6). Double-click on 
the icon to launch the software. 
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Figure 6. The desktop Icon 

9. Initial screen on launching the DVP Eval Software is shown on Figure 7. At this stage it may be necessary to 
update your install with the Board Files for the evaluation platform you intend to work on. 

 

Figure 7. Initial screen of DVP Eval Software 

10. A Folder with the correct devices files must be placed in xml\New Boards Folder. Simply copy whole 
content of ADV7630 directory into New Boards. 
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Figure 8. New boards folder – example 

 

11. Within the DVP Eval Menu select : File-> Update Devices. 

 

Figure 9. Updating boards (1) 

 

12. A pop up window notifies the user that the update was successful. 

 

Figure 10. Updating boards (2) 

13. The Folder with the device files is moved into a subfolder within New Boards called ‘Recent Boards 
Added.’ 
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3.2 Loading/Unloading Boards 

3.2.1  Loading a Board 
The following steps must be performed to start a new DVP Eval session by loading a new board. 

1. Click “Choose Board…”  

 

2. Figure 11. Choose board button 

3. From the Board Selector window, select your attached system e.g. “ADV7630” as RX, “None” for 
MotherBoard and “None” for TX. 

4. Click “Load” 

 

Note: If the board is standalone, select the board in whichever window it is populated under (i.e. RX, 
Motherboard, TX) and leave the other windows at “None”. 
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Figure 12 - Board Selection 

3.2.2  Unloading a Board 
The following steps must be performed to end an DVP Eval session by unloading the selected board. 

1. Select Files -> Unload Boards 
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3.3 Running Scripts 
Scripts can be run by either of the following options: 

 

1. Select Scripts -> Project Name e.g. ADV7630 

2. Follow the script tree as outlined in the expanding menus (see Figure 13) 

3. Select Scripts -> Run Script 

4. Open the script folder of the desired project 

5. Select the desired script and click “Open” 

 

Please be patient as the script may take several seconds to run. Successful download of the script is notified by the 
green light at the bottom of the screen flashing twice. 

 

 
Figure 13 – DVP Eval Script Tree 
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3.4 Other DVP Eval Features 
 

3.4.1 Register Control 
The following steps must be performed to use DVP Eval Register Control: 

 

1. Select Tools -> Register Control 

2. Enter the Device Address in HEX (see Figure 14) 

3. Enter the desired register address in HEX 

4. Press the “Write” button to write a value to the selected register 

5. Press the “Read” button to read a value from the selected register 

 

 

Figure 14 - Register Control Window 
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4. The ADV7630 Evaluation Platform in Depth 

4.1 Hardware Overview 
The following features of the ADV7630 evaluation board should be noted 

4.1.1 Connectors 

1. 4 x HDMI inputs (J2,  J3, J6, J8) 

2. 2 x HDMI outputs (J5, J7) 

3. 1 x UART connector (J11) 

4. 1 x USB connector (J12) 

5. 1 x Power Supply Connector (J10) 

4.1.2 Jumpers 
Microcontroller 

1. MUC boot ROM location (K2) – default position ‘B’ 

2. MUC reset (K1) – default position ‘not inserted’ 

3. Microcontroller reset control (K9) – default position ‘not inserted’ 

4. UART (K4) - default position ‘not inserted’ 

Power 

5. DVDD-JP  (must be inserted) 

6. TX_AVDD-JP  (must be inserted) 

7. TXA_PVDD-JP (must be inserted) 

8. TXA_PVDD-JP (must be inserted) 

9. TXB_PVDD-JP (must be inserted) 

10. TX_TVDD-JP (must be inserted) 

11. SYS_3P3V-JP (must be inserted) 

12. DVDDIO-JP (must be inserted) 
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4.1.3 Switches & Buttons 

1. ON/OFF (S1) 

2. Software enable/disable (S3) 

3. DUT reset (S4) 

4. MCU reset (S2) 

 

4.1.4 Miscellaneous 

1. 1x 20 way connectors (J9) 

2. Software driver LEDS (LED1, LED2, LED3, LED4, LED5, LED6) 

3. I2C header (P1) 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 15 - ADV7630 Evaluation Platform 
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4.2 Using the ADV7630 Evaluation Platform 

4.2.1 Connecting an Input Video Source 
To connect an input video source to the ADV7630 evaluation board, use a HDMI cable and the input HDMI 
connector to J2, J3, J6 or J8. Do not use excessive force when connecting or disconnecting the cable as this may 
result in damage to the evaluation board.  

4.2.2 Connecting to a Video Sink 
To connect the ADV7630 evaluation board to a video sink, use a HDMI cable and the output HDMI connector to J5 
or J7. Do not use excessive force when connecting or disconnecting the cable as this may result in damage to the 
evaluation board. 

4.2.3 Updating the Software Driver 
To download updated software driver code to the microcontroller used on the ADV7630 evaluation board, please 
perform the following steps 

1. Power off the board  

2. Insert jumper K4 

3. Ensure jumper K2 is in position A 

4. Ensure that jumper K1 (MCU RESET) is not inserted 

5. Connect a serial cable between the computer to be used for the download and the UART connector (J11), 
on the ADV7630 evaluation board 

6. Power on the board by moving the ON/OFF switch (S1) to position ON. 

7. Start the Flashmagic download by pressing “Start”. For information on where to obtain and how to use the 
Flashmagic tool, please see Appendix 3 – Flash Magic. 

8. When the download has completed, power off the board by moving the ON/OFF switch (S1) to position 
OFF.  

9. Remove jumper K4. 

10. Ensure jumper K2 is in position B. 

11. Power on the board by moving the ON/OFF switch (S1) to position ON. 

 

If the Flash magic tool gives a warning, please check the setup and jumper positions carefully.  

 



Eval Note  
 

Rev. A Page 17 of 30 
 

4.2.4 Interfacing with the Software Driver 
Jumper K1, when inserted, pulls the microcontroller reset low. To use the software driver, please ensure that K1 is 
removed. 

To stop and start the software driver (e.g. to allow access to the I2C over DVP Eval), toggle the SW_ENABLE (S3) 
switch on the evaluation board. When disabled, the driver will send the message “REP: Driver Disabled”. When 
enabled, the driver will send the message “REP: Driver Enabled” and any status updates will be displayed.  

Please see the software driver documentation for the functions performed by software driver LEDS (LED1, LED2, 
LED3, LED4, LED5, LED6). To enable the software driver, switch the software enable switch (S3) to SW_ENABLE. 
To disable the software driver, switch the software enable switch (S3) away from SW_ENABLE. 

For information on the latest software driver, please contact your local FAE or sales office. 
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Appendix 1 – Schematics 
  

   

               

           

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 8. T ransciever schematics  
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Figure 9. ARM7 schematics  
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Figure 10. HDMI-IN/HDMI-OUT schematics 
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Figure 11. USB Circuitry schematics  
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Figure 12. Power supply schematics 
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Appendix 2 – Layout 

 

Figure 16: Layout Silkscreen (Top) 
 

Figure 17: Layout Layer 1 (Top) 
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Figure 18: Layout Layer 2 (GND) 

 

Figure 19: Layout Layer 3 (PWR) 
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Figure 20: Layout Layer 4 (Bottom) 

 

Figure 21: Layout Silkscreen (Bottom) 
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Appendix 3 – Flash Magic 
 

Software Setup: the Flashmagic tool can be downloaded from www.flashmagictool.com. Analog Devices does not 
take responsibility for the content of any external sites.  

 

Note: Please ensure the tool settings are configured to “Use DTR and RTS to control RST and ISP pin”. The tool 
settings are accessed by navigating through Options -> Advanced Options -> Hardware Config. 

 

All other main settings should be as follows: 

- Device: LPC2468 

- COM: As per user device 

- Baud rate: 115200 

- Interface: None (ISP) 

- Oscillator: 14746 

- Ensure “Verify after programming” is enabled 

- Ensure “Erase blocks used by Hex File” is enabled 

- Specify filename to download 

 

http://www.flashmagictool.com/
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Appendix 4 – Downloading from FTP 
 

Using an FTP client (e.g. Filezilla – http://filezilla-project.org/download.php?type=client - Analog Devices does not 
take responsibility for the content of any external sites), please log on to download the latest evaluation software.  

 

Host: ftp.analog.com 

Username: e.g. ADV7630 

Password: supplied from FAE/product line 

Port: leave empty (FTP client will automatically populate this)  

 

 

Figure 22 - Filezilla Settings 

http://filezilla-project.org/download.php?type=client
ftp://ftp.analog.com/
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Appendix 5 – Software Driver Controls 
 

When using the software driver, please connect a UART terminal e.g. Hyperterminal or TeraTerm for feedback on 
the status of the software driver.  

 

 

Figure 23.  Software driver feedback 

 

Please use the following commands to interface with the software driver 

?         Print help 

help      Print help 

amute     Mute audio output <on or off> 

arctx     ARC TX mode <on or off> 

avmute    Send AVMUTE <on or off> 

cec       CEC support <on or off> 

dbg       Select debug output [rx] [tx] [hdcp] [edid] [cec] [int] [none] [all] 

dbg+      Same as dbg command with output addition 
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dbg-      Same as dbg command with output removal 

enc       Output encryption <on, off or us(same as upstream)> 

fs        Fast switching <on or off> 

i2cr      i2c read <device> <register> <byte count> 

i2cw      i2c write <device> <register> <value> 

i2cand    i2c AND register with value <device> <register> <value> 

i2cor     i2c OR  register with value <device> <register> <value> 

i2cxor    i2c XOR register with value <device> <register> <value> 

i2cdbg    i2c debug <device addr, dev addr, ...> 

memr      Read memory <address(32-bit aligned)>  <byte count> 

memw      Write memory <address(32-bit aligned)> <value> 

mode      Set operating mode <rec, rep, xmt or auto> 

mute      Set mute mode <man or auto> 

mtime     Set mute times in ms <For TMDS, For Blackout> 

out       Set TX output <hdmi, dvi, us or forced> 

port      Select input port <a, b, c, d, e, f, g n(none) or t(auto)> 

reset     Reset system 

run       Resume software 

stat      Print system status 

stop      Stop software 

vmute     Video output mute <on or off> 

edidmod   Update RX EDID <on or off> 

           EDID will be modified before being written to the RX internal EDID. 

           Refer to REP_EVENT_TX_EDID_READY event processing in rep_notify.c 

power     Power <on or off>, <mode 0 or 1> 

cecaudio  send cec message about audio <opcode>, <directly addressed >,  

          <parameters> 

xmtmode   When no HDMI input connected (MXT mode), keep HDMI TX on or off 

          <on or off> 
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UART Terminal Settings 

- Baud rate: 115200 

- Data: 8-bit 

- Parity: none 

- Stop: 1-bit 

- Flow control: none 
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