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PRODUCT INFORMATION
Product information can be obtained from the Analog Devices Web site and other Web sources.
Analog Devices Web Site
The Analog Devices Web site, www.analog.com, provides information about a broad range of products
analog integrated circuits, amplifiers, converters, and digital signal processors. To access a complete
technical library for each video product family, go to http://www.analog.com/en/audiovideoproducts/products/index.html.
Also note, MyAnalog.com is a free feature of the Analog Devices Web site that allows customization of a
Web page to display only the latest information about products you are interested in. You can choose to
receive weekly e-mail notifications containing updates to the Web pages that meet your interests, including
documentation errata against all manuals. MyAnalog.com provides access to books, application notes, data
sheets, code examples, and more. Visit MyAnalog.com to sign up. If you are a registered user, just log on.
Your user name is your e-mail address.
Engineer Zone
Engineer Zone is a technical support forum from Analog Devices. It allows you direct access to Analog
Devices technical support engineers. You can search FAQs and technical information to get quick answers
to your questions about Analog Devices video products at http://ez.analog.com/community/video.
COPYRIGHT INFORMATION
© 2012 Analog Devices, Inc., ALL RIGHTS RESERVED. This document may not be reproduced in any
form without prior, express written consent from Analog Devices, Inc.
DISCLAIMER
Analog Devices, Inc. (ADI) reserves the right to change this product without prior notice. Information
furnished by Analog Devices is believed to be accurate and reliable. However, no responsibility is assumed
by Analog Devices for its use; nor for any infringement of patents or other rights of third parties which may
result from its use. No license is granted by implication or otherwise under the patent rights of Analog
Devices, Inc.
The information contained in this document is proprietary of ADI. This document must not be made
available to anybody other than the intended recipient without the written permission of ADI.
The content of this document is believed to be correct. If any errors are found within this document or if
clarification is needed, contact the video community on EZ forum (http://ez.analog.com/community/video).
TRADEMARK AND SERVICE MARK NOTICE
The Analog Devices logo is a registered trademark of Analog Devices, Inc. The Advantiv® and Blackfin®
are registered trademarks of Analog Devices Inc. All other brand and product names are trademarks or
service marks of their respective owners.
All other brand and product names are trademarks or service marks of their respective owners.
Analog Devices’ Trademarks and Service Marks may not be used without the express written consent of
Analog Devices, such consent only to be provided in a separate written agreement signed by Analog
Devices. Subject to the foregoing, such Trademarks and Service Marks must be used according to Analog
Devices’ Trademark Usage guidelines. Any licensee wishing to use Analog Devices’ Trademarks and
Service Marks must obtain and follow these guidelines for the specific marks at issue.
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1.0 INTRODUCTION
This user-guide is intended to provide user hardware and software support to run the transceiver cross-point
and splitter Application on ADV7625 evaluation platform. It provides details on the setup of the evaluation
platforms in order to run the application and also how to interface with the application.
1.1 CROSS POINT APPLICATION

The Cross Point application is an example software application designed to demonstrate the use of the cross
point and splitter in a typical application. When running, the cross point application configures the device
to route data from any of the HDMI inputs to any of the two HDMI outputs and the splitter application
configures the same input to be routed to both of the HDMI outputs.
The user may control and query the application via the serial interface on the ADI evaluation platform. The
application also provides feed back to the user about the application status and application events via the
serial interface. The following sections in this document describe the main user functions.
The application software was developed using ADI’s software API Libraries.
2.0 HARDWARE
2.1 HARDWARE PLATFORM
The cross point application targets this platform EVAL-ADV7625-SMZ platform (using the Blackfin®
BF524 processor)
Eval ADV7625 SMZ platform is standalone and requires the following
 Evaluation board
 5 V 3.6A DC power supply module
Please contact your local ADI representative if you require assistance in ordering any of the required
evaluation boards.
The following section provides basic information on how to get started with the evaluation platform. For
more details please refer to the relevant evaluation board user-guide.
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2.1.1 Initial Board Setup
The evaluation platform setup should be as follows.
1. Connect the DC power supply module to the power connector. Turn on main power switch. Power
LED should illuminate.
3.0 SOFTWARE
3.1 SELECTING THE APPROPRIATE FIRMWARE
It is important to match the application firmware to the hardware. As there are many ADI chips and
hardware combinations and applications available the firmware loaded on the board must target the same
devices as your hardware.
The processor on EVAL-ADV7625-SMZ platforms is an Blackfin processor, it is programmed via a .bin
file. The following example works through the selection of a bin file appropriate for a particular standalone
platform.
For example if your hardware is a EVAL-ADV7625-SMZ platform an appropriate file would be
BF_7625_7625_xxxxxxxxx.bin
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The application type, and target devices can be read from the file name.
For example: BF_7625_7625_X2.2_RC2_20130815.hex
BF_7625_7625– This will be the name of the platform followed by the target device name
Note: In some applications, Tx and Rx will differ. In such cases, Rx device name will be followed by Tx
device name.
X2.0_RC2=> Cross point Application Revision 2.0RC2
20130815=> revision tag created on Date 15th August 2013
Following power up the revision details will be printed to the serial terminal. Below is an example of an
printout of the X-Point application details.
********************************************************************
ADI X-Point Repeater Application Ver R2.0.2
PLATFORM: DVP 7625 EVAL Rev 0xff
HDMI-RX: ADV7625 Rev 0x4082
HDMI-TX: ADV7625 Rev 0x0
Created: Aug 15 2013 At 12:21:52
********************************************************************
3.2 UPGRADING FIRMWARE
This section describes the procedures to download the firmware on Blackfin-based platforms.
3.2.1. Up-grading Application Firmware on EVAL-ADV7625 SMZ platform:
The software (firmware) on the evaluation board can be upgraded using the standard Blackfin development
tools.


VisualDSP++ 5.1.2



JTAG debugger for Blackfin processors (HPUSB-ICE or ICE-100B or ICE-1000) connected to the
JTAG connector (J7)

Using these tools, you can connect to the ADSP-BF524 processor, run a script, and program the SPI flash
memory device (U10).
With that said, new evaluation boards are being shipped with the U-Boot boot loader firmware. If this is the
case, you have the option of upgrading the firmware using only an RS-232 cable and software.
If you see the following output after resetting the board or applying power, your evaluation board has UBoot:
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------------------U-Boot 2010.06 (ADI-2010R1-RC2) (Jan 12 2011 - 15:53:34)
CPU: ADSP bf524-0.2 (Detected Rev: 0.2) (spi flash boot)
Board: ADI Advantiv™ Video Evaluation Board
Support: http://ez.analog.com
Clock: VCO: 300 MHz, Core: 300 MHz, System: 100 MHz
RAM: 8 MiB
SF: Detected M25P80 with page size 256, total 1 MiB
In: serial
Out: serial
Err: serial
KGDB: [on serial] ready
Hit any key to stop autoboot:
------------------If your evaluation board has U-Boot, you can use the following steps to upgrade the application firmware of
your board (if you determine this is necessary). Note that these instructions assume you are using the latest
version of Tera Term for Windows (which is free to download and use), but any RS-232 software with
Ymodem upload capability should also work.
1. After you see the hit any key to stop autoboot prompt, press a key during the countdown. You should
then see a prompt, bfin >.
2. At the prompt, type the following command:
sf probe 0:1
You should see the following:
SF: Detected M25P80 with page size 256, total 1 MiB
1024 KiB M25P80 at 0:1 is now current device
bfin>
3. At the prompt, type the following command:
loady
You should see the following output:
## Ready for binary (ymodem) download to 0x00100000 at 115200 bps...
C
4. In Tera Term (a terminal software application) , under File, click Transfer, then YMODEM, and select
Send…
5. Select the application firmware (for example, BF_7625_7625_xxxxxx.bin) and click Open.
6. You should see the YMODEM send dialog box progress quickly from 0% to 100%. If the software stalls
at Packet 1 or Packet 2 for a few seconds, you may need to cancel and retry. It is possible that you may
need to repeat Step 3 through Step 5 a few times to accomplish the transfer. After the transfer is
complete, you should see the following:
CCxyzModem - CRC mode, 0(SOH)/215(STX)/0(CAN) packets, 5 retries
## Total Size = 0x000357fc = 219132 Bytes
bfin>
7. At the prompt, type the following command to erase the application area of the SPI flash memory:
sf erase 0x60000 0xa0000
You should then see the following output:
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bfin>
8. At the prompt, type the following command to program the application area of the SPI flash memory:
sf write $(loadaddr) 0x60000 $(filesize)
You should then see the following output:
bfin>
9. At this point, if you reset your board and allow the countdown to complete, U-Boot should launch the
application firmware that you just programmed
3.2.2. Up-grading OSD Firmware on EVAL-ADV7625 SMZ platform:
In Blimp tool, under Project settings->Build->Memory Configuration if the External flash memory option is
selected as shown in below Figure 1, then you need to upgrade the OSD firmware file to get the valid OSD.
If internal flash memory option is selected then no need to update the OSD firmware.

Figure 1
The OSD firmware can be upgraded using UART interface.
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Upgrading via UART interface
Your new evaluation boards are being shipped with the U-Boot boot loader firmware then, you have the
option of upgrading the OSD firmware using an RS-232 cable and software.
If you see the following output after resetting the board or applying power, your evaluation board has UBoot:
------------------U-Boot 2010.06 (ADI-2010R1-RC2) (Jan 12 2011 - 15:53:34)
CPU: ADSP bf524-0.2 (Detected Rev: 0.2) (spi flash boot)
Board: ADI Advantiv™ Video Evaluation Board
Support: http://ez.analog.com
Clock: VCO: 300 MHz, Core: 300 MHz, System: 100 MHz
RAM: 8 MiB
SF: Detected M25P80 with page size 256, total 1 MiB
In: serial
Out: serial
Err: serial
KGDB: [on serial] ready
Hit any key to stop autoboot:
------------------After you see the ‘hit any key to stop auto boot prompt’, press a key during the countdown.
You should then see a prompt,
bfin>
At the prompt, type the following command sf probe 0:2 to select the flash and press enter
You should see the following:
SF: Detected M25P80 with page size 256, total 1 MiB
1024 KiB M25P80 at 0:2 is now current device
bfin>
At the prompt, type the following command to erase the flash sf erase 0x0 0x100000 and press enter
You should see the following:
bfin>
At the prompt, type the following command: loady and press enter
You should see the following output:
## Ready for binary (ymodem) download to 0x00100000 at 115200 bps...
C
In Tera Term, under File, click Transfer, then YMODEM and select Send.
Select the OSD binary file (for example, ddr2_dump.bin) and click Open.
After the transfer is complete, you should see the following:
CxyzModem - CRC mode, 0(SOH)/16(STX)/0(CAN) packets, 6 retries
## Total Size = 0x00003a12 = 14866 Bytes
bfin>

At the prompt, type the following command to program the SPI 7625 flash memory
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sf write $(loadaddr) 0x00 $(filesize) and press enter
You should then see the following output:
bfin>
At this point, power cycle the hardware and flash the application data to verify the OSD.
3.3 CONFIGURING THE UART INTERFACE
The Advantiv repeater application includes a debug feature where the application sends event and debug
messages via the serial interface.
The user may avail of this feature by connecting, via an RS-232 cable, their PC’s serial port to the serial port
of the evaluation board use a suitable serial terminal application with the following settings to retrieve the
debug feedback.






115200 baud rate
8 data bits,
1 stop bit
no parity
no flow control

3.4 RUNNING THE APPLICATION
This section describes controls to start and interact with the application.
The application starts to run when the evaluation board is powered on.
3.4.1 Serial port commands
The main way to interface and control the X-point application is via the serial port. There are a number of
commands that are supported.
Type ‘help’ to get a list of supported commands in BF-based Evaluation platform. Below is a list of the
basic commands available. Note some features may depend on the platform devices and application features
and capability.
Command Description and parameters for Blackfin-based platform (All data in hex)
Type ‘help’ to get a list of supported commands in Advantiv Evaluation platform. Below is a list of the
basic commands available. Note some features may depend on the platform devices and application features
and capability.
>help
Advantiv Video Evaluation Board Software Version: 2.2 built on Jun 25 2014 at 14:44:52
I2C Commands assume hex numbers: don't use 0x
wri2c <device> <address> <data><CR> writes a single I2C register
rdi2c <device> <address><CR> reads a single I2C register
dump <device> <start address> <numreads><CR> reads numreads bytes sequentially from start address
help<CR> prints this list
startrep<CR> starts/restarts the repeater software
stoprep<CR> starts/restarts the repeater software
rep <command><CR> sends an arbitrary <command> to the repeater handler
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rep help<CR> will list the repeater commands currently available
res7625<CR> resets the ADV7625
hdmia a/b<CR> changes to HDMI Port A TXA/TXB
hdmib a/b<CR> changes to HDMI Port B TXA/TXB
hdmic a/b<CR> changes to HDMI Port C TXA/TXB
hdmid a/b<CR> changes to HDMI Port D TXA/TXB
hdmie a/b<CR> changes to HDMI Port E TXA/TXB
Type ? also to get the list of commands.
>?
Command Description and parameters (All data in hex)
?
Print this message
help
Print this message
rev
Get software revision
reset
Reset system
run
Resume software
stop
Stop software
stat
Print system status <Repeater Index: 1,2,.. >
route
Video routing, <PortIndex: a,b,c...> <Tx Output: txa,txb..>
edidmod Enable EDID Modification, <Enable:on,off>
edidmrg Enable/Disable EDID merge and send to RX, < On, Stop ,Off>
audext
Extract Received audio, <Enable :on, off>
audrep
Inserts audio from APx_IN pins to Tx, <Enable :on, off>
audioparam Sets Audio Parameters <txa,txb> <I2S format > <Audio Sampling Frequency> <Audio
Channel Count > <Audio Word Length>
mux
Enable Mux Mode, <Rx Input: 1,2,.. > <Enable :on, off>
csc
Color Space Conversion on TX <txa,txb> <rgb, rgb_full, 601, 709, auto>
-- when splitter mode is enabled giving either txa or txb in command will set csc for both tx
enc
Set Output Encryption Mode <Configuration:on, off, us(same as upstream) or rxtx (seperate RX
and TX)>
power
Power <on or off>, <mode 0,1,2>
dbg
Select debug output <rx, tx, hdcp, edid, cec, int, none, all>
dbg+
Same as dbg command with output addition
dbgSame as dbg command with output removal
i2cr
i2c read <device> <register> <byte count>
i2cw
i2c write <device> <register> <value>
i2cand i2c AND register with value <device> <register> <value>]
i2cor
i2c OR register with value <device> <register> <value>
i2cxor i2c XOR register with value <device> <register> <value>
i2cdbg i2c debug <device addr, dev addr, ...>
audtestmode Turn on the Audio Certification Mode to test with certification streams from AP machine <on
or off>
limitmclk
Limits MCLK Frequency, <RepPath:1,2><on or off><minvalue><maxvalue>w
sethpd
Manually asserts RX hpd to low or high, <rep path > < high or low>
spaset
Manually set SPA value for RX ports, <port 0/1/2/3/4 > < SPA value>
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APPENDIX A: OSD INTEGRATION FROM BLIMP TO HDMI
SOFTWARE
A.1 SETUP REQUIRED



Blimp tool
VisualDSP++ 5.1.1

A.2 STEPS TO INTEGRATE OSD PROJECT INTO HDMI SOFTWARE DRIVER

A2.1 FOR FIRMWARE:


Please refer Blimp user manual for designing and verifying OSD with emulator https://ez.analog.com/docs/DOC10635



After verifying the OSD functionality in emulator window, now go to firmware folder in blimp project files
<ProjectFiles>\Release\firmware and copy it

Figure 12



Paste the firmware folder in to HDMI software driver <Project folder>\APP\XREP\OSD\Firmware. Before pasting
the firmware folder, please ensure that all the files/folders under firmware are deleted in HDMI software driver.
Please note that Firmware only needs to be updated when updating blimp version, otherwise firmware code is
the same for every build
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Figure 13
If ADI HDMI software driver is used to development, set the USE_EXTERNAL_TYPE value to 1
in the osd_types.h file

A2.2 FOR PROJECT FILES:


Any file starting with blimp_* should be deleted first or any files not found in Blimp project release folder should be
removed. This would be the case if a OSD page is deleted.



Finally copy the OSD generated *.c and *.h files from <Blimp Project folder>\Release into HDMI software driver
folder <Project folder>\APP\XREP\OSD\ DemoOsd as like the below reference Figure 14
Please do not delete/replace the externalApi.c and externalApi.h files and keep the functions same as driver
code and blimp code.
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Figure 14
Now you can build your HDMI Software driver code using VDSP and check the OSD on evaluation board.
Refer Blimp user manual for updating OSD flash file https://ez.analog.com/docs/DOC-10635
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APPENDIX B: BASIC GUIDELINES FOR COMPILING THE PROJECT IN VDSP
This Appendix specifies the sequence of steps to compile a project, debug a project and project configuration settings in
VisualDSP++ Environment.

B.1 SETUP REQUIRED




VisualDSP++ 5.1.1
Product Version: 5.1.1.0
IDDE Version: 8.0.7.22

B.2 PROJECT SETTINGS TO DO


Select Project -> Project Options and set all the configuration settings as shown in Figures from 1 to 18.

Figure 1


Select General -> set the folders for output directories as shown in Figure 2.
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Figure 2


Select Compile -> then General -> Enable the options as shown in Figure 3.

Figure 3



Select Compile -> Preprocessor -> In Preprocessor definitions add two definitions as shown in below Figure 4.

Page 18 of 34

ADV7625 Cross Point Application User Guide

Figure 4



Select Compile -> Preprocessor -> In Additional include directories, add all the include directories in the HDMI
software driver as shown in below Figure 5.

Figure 5
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Select Compile -> then Processor (1) -> Enable the options as shown in Figure 6.

Figure 6



Select Compile -> then Processor (2) -> Enable the options as shown in Figure 7.

Figure 7



Select Assemble --> Enable the options as shown in Figure 8.
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Figure 8



Select Link -> then General -> Enable the options as shown in Figure 9.

Figure 9



Select Link -> then LDF Processing -> Set the macro definitions as shown in Figure 10.
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Figure 10



Select Link -> then Processor (1) -> Enable the options as shown in Figure 11.

Figure 11
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Select Load -> In Options menu, enable the options for Boot mode and add the output file name as needed as shown
in below Figure 12.

Figure 12



Select Remove Startup Code/LDF -> Enable the options as shown in Figure 13.

Figure 13


Select LDF Settings -> In External Memory, set the Custom size of memory as shown in below Figure 14.
Page 23 of 34

ADV7625 Cross Point Application User Guide

Figure 14



Select LDF Settings -> In System Heap, set the type and size of memory as shown in below Figure 15.

Figure 15

Page 24 of 34

ADV7625 Cross Point Application User Guide



Select LDF Settings -> In User Heap, set the Memory types and Heap size of memory as shown in below Figure 16

Figure 16



Select LDF Settings -> In System Stack, set the Memory types and Stack size of memory as shown in below Figure
17.

Figure 17
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Select LDF Settings -> Advanced Options -> Enable the options as shown in Figure 18.

Figure 18


Select Startup Code Settings -> Cache and Memory Protection -> Enable the options as shown in Figure 19.

Figure 19
Page 26 of 34

ADV7625 Cross Point Application User Guide

B.3 ADDITIONAL SETTINGS TO DO


Select Settings->Target Options and enable the check boxes as shown in Figure 20.

Figure 20


Select Settings->Preferences and enable the check box as shown in Figure 21.

Figure 21
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B.4 STEPS TO BUILD PROJECT




Open VDSP tool. Select File->Open->Project
Browse to the location where the required project is present and select it.
Select View->Project Window, View->Output Window, View->Status Bar, and View -> Editor Tab.
You can see the display as shown in Figure 22.

Figure 22


Right Click the Project folder and select Clean Project. You can see the progress in Output Window as "Deleting
intermediate and target files... Done."Refer Figure 23 and Figure 24.

Figure 23
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Figure 24



Right Click the Project folder and select Rebuild Project. You can see the progress in Output Window as" Creating
loader file... [Warning ld0172]: File, EVALADV7625SMZ\BF_7627_XREP_X2.3_RC1_20141031.bin, does not
match the standard extension: .ldr. Build completed successfully." Refer Figure 25.
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Figure 25


Now binary is created and can be found in the EVALADV7625SMZ folder. Flash the created binary in hardware
using the procedure given in user guide of the Evaluation platform.



Note: When VDSP is installed for the first time and if we try to load program we will get an error as like “External
memory not enabled". We need to change the ArchDef file for corresponding BF processor. Replace the ADSPBF524-proc.xml file in installation path with the attached file.

ADSP-BF524-proc.x
ml

B.5 STEPS TO DEBUG PROJECT


Connect the Emulator to the JTAG interface in Blackfin processor board.
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Select Session->New Session.
Select processor family as Blackfin. Choose Target Processor as ADSP-BF524 as shown in Figure 26.

Figure 26


Click Next and choose Connection type as Emulator as shown in Figure 27.

Figure 27
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Click Next. Enter the session name & select the platform you want to connect with. (Example: ADSP-BF524 via
HPUSB-ICE). Refer Figure 28.

Figure 28


Click Next then click Finish. Refer Figure 29.

Figure 29



Now you can see the VDSP window showing as Target Connected. Refer Figure 30.
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Figure 30


If emulator is not connected properly with hardware or if you selected a wrong target name under Select Platform
window, you will get an error message after selecting Finish as shown below. Refer Figure 31.

Figure 31





Select File->Load Program and choose the .dxe file created after project build.
Select Debug->Run.
Under Debug, there are options for stepwise debugging like Step Over, Step Into and Step out of .
For stepwise debug, you need to insert a breakpoint in a particular line in project code and then select Debug->Step
Over/Step Into/Step out of.



To insert Breakpoint, double click particular line on left side in project file as shown below in Figure 32.
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Figure 32


Select Debug ->Halt to stop running the project.
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