ADAU1961_Audio Coupling Issue

HI Analog Team!

I am using ADAU1961 in my Board in Capless headphone configuration with RHP,LHP and Monoout pins connected to a 5ring Audio Jack, I have enabled Volume Control and if i Keep 0dB Sound level in RHP and -57dB or mute in LHP, there seems to be Audio coupled(356mVpp is observed) in my left ear also. Is there some configuration or hardware connections i have Missed?

Also, when i connect the Monoout to GND, the coupling gets considerably reduced, is it advisable to GND Monoout?

Thanks in Advance,

Devaguru

  • Dear Team,
     
    I am using audio codec chip ADAU1961 in my module in cap-less headphone configuration. RHP, LHP and mono-out pins are connected to a 5 Ring Audio Jack as per EVM Schematic(recommendation).
     
    Kindly find the below register details were used for cap-less headphone configuration.
     
    0x4000,0xF
    0x4000,0xF
    0x4000,0xF
    0x4002,0x027101DD
    0x4002,0x1B01
    0x4000,0xF
    0x4008,0x0
    0x4009,0x0
    0x400A,0x0
    0x400B,0x0
    0x400C,0x0
    0x400D,0x0
    0x400E,0x0
    0x400F,0x0
    0x4010,0x0
    0x4011,0x0
    0x4012,0x0
    0x4013,0x0
    0x4014,0x0
    0x4015,0x1
    0x4016,0x22
    0x4017,0x4
    0x4018,0x0
    0x4019,0x0
    0x401A,0x0
    0x401B,0x0
    0x401C,0x21
    0x401D,0x0
    0x401E,0x41
    0x401F,0x0
    0x4020,0x0
    0x4021,0x0
    0x4022,0x1
    0x4023,0xE7
    0x4024,0xE7
    0x4025,0x0
    0x4026,0x0
    0x4027,0xE7
    0x4028,0x0
    0x4029,0x3
    0x402A,0x7
    0x402B,0x0
    0x402C,0x0
    0x402D,0xAA
    0x402E,0x0
    0x402F,0xAA
     
    We are facing that one side(either left or right) muting is not happening. We tried with these configuration listed below.
     
    1) On configuring R29: Playback Headphone Left Volume Control as -57dB & mute at register 0x4023 as 0x01, LHP volume gets reduced(audible) but not muted in left headset.
     
    While probing LHP pin, we observed 181mVpp signal (in-phase with RHP pin)
    On probing mono out pin, we observed 419mVpp signal (in-phase with RHP pin)
     
    Similar configuring were done at R30: Playback Headphone Right Volume Control were set as -57dB & muted. RHP volume gets reduced(audible) but not muted in right headset.
     
    Note1: The above observations are found only when the headset is connected, when it is disconnected mono-out and the muted channel were remains at AVDD/2(No Signal).
    Note2: Headset impedance - 38 Ohm
     

    2)To overcome the above observation (1) the following configurations was changed with above configuration register details.
     
    i) DAC → left (disabled) + right (enabled)            => R36: DAC Control 0 (0x402A) set to 0x06
     
    ii) Mixer3 left and right input (mute + disabled)    => R22: Playback Mixer Left (Mixer 3) Control set to 0x00
     
    iii) Left Volume (0dB + mute)                                 => R29: Playback Headphone Left Volume Control set to 0x01
     
    Even after performing the above changes, the signal is present in mono-out and LHP pins with common mode voltage of AVDD/2.
     

    3)Is it possible to perform channel mute in this part for cap-less headphone configuration?


    Awaiting your response.

    -- 
    Thanks & Regards,
    Devaguru V