I2C communacation failure with SSM2529 which marked with "Y4D #KK"

Hi

I use SSM2529 which marked "Y4D #L1" and "Y4D #O1" , I2C communacation is normal

but,  the SSM2529 which marked "Y4D #KK" is abnomal,I2C communacation is fail .

Someone’s design has exactly the same issue.But there is no answer.

The url FYI

ez.analog.com/.../390610

ez.analog.com/.../i2c-communacation-failure-with-ssm2529

My SCH



初步确定这个丝印的物料为不良品,至于怎么流出无从知晓,只有ADI官方清楚!!!同样的物料在ADI demo板上同样不能I2C通讯!!!
[edited by: YanXu at 3:51 AM (GMT -4) on 31 Oct 2020]
  • It is preliminarily determined that the SSM2529 which marked “KK”IC  is defective. As for how it flows out, it is unknown, only the ADI official knows! ! ! The SSM2529 whitch marked “KK”IC cannot communicate with I2C on the ADI SSM2529 demo board! ! !

  • 0
    •  Analog Employees 
    on Nov 2, 2020 3:53 PM 4 months ago in reply to YanXu

    Hello,

    Sorry to hear about the issue. The Eval Boards are shipped with USBi and are tested before packing. It might be good to understand the issue on your specific EVB. Are you using the USBi ( small USB board) with IDC cable to attach to the EVB?

    Please note the USBi driver needs to be installed using the SigmaStudio Software available on analog.com. If you have already followed all the steps correctly and still see the issue then please send the SStudio file you used for communicating with the part. It would also help if you could end the I2C scope captures to see if the clocks are going correct to the EVB. Is it possible for you to share this information?

    It should be possible to ask for replacement if the EVB you received is faulty. The local sales should be able to help you with the return or replacement.

    Regards

    Rajeev

  • On my board,I use SSM2529 which marked "Y4D #L1" and "Y4D #O1" , I2C communacation is normal

    but,  the SSM2529 which marked "Y4D #KK" is abnomal,I2C communacation is fail .

    Someone’s design has exactly the same issue.But there is no answer.

    On demo board,the SSM2529 which marked "Y4D #L1" ,the I2C work normal,but the SSM2529 which marked "Y4D #KK"  work failed.

    The deom board have no issue.