SigmaStudio Network Utility for Linux seems to be outdated

SigmaStudio Network Utility for Linux seems to be outdated.  Based on debugging I have made, the protocol has changed in some stage.  Is there any working code available anywhere?  The latest version here https://github.com/analogdevicesinc/sigma-tcp doesn't really work.

I have understanding on the writing commands but register read command is mystery as the latest information on the response packet format doesn't seem to work.

Parents
  • SigmaStudio 3.13.

    As I am a Linux user, I run SigmaStudio in Windows under VirtualBox.  It works just great with FreeUSBi.  What I would like to achieve, is to get this working with Arduino communicating over serial from the Linux side.  Only missing piece is the  program for Linux which handles the communication from SigmaStudio over TCP and forwards that to Arduino for I2C.  I have some working code written in Python.  I can decode all writing packets correctly, they match the data which is written by FreeUSBi.  Only missing part is the reading packet format.  The format I have seen documented doesn't work.

    If I will get this working, I'll put my code, both Python script and the Arduino sketch available for anyone to use.

Reply
  • SigmaStudio 3.13.

    As I am a Linux user, I run SigmaStudio in Windows under VirtualBox.  It works just great with FreeUSBi.  What I would like to achieve, is to get this working with Arduino communicating over serial from the Linux side.  Only missing piece is the  program for Linux which handles the communication from SigmaStudio over TCP and forwards that to Arduino for I2C.  I have some working code written in Python.  I can decode all writing packets correctly, they match the data which is written by FreeUSBi.  Only missing part is the reading packet format.  The format I have seen documented doesn't work.

    If I will get this working, I'll put my code, both Python script and the Arduino sketch available for anyone to use.

Children
No Data