EVAL-ADICUP 3029 not programming

Dear analog,

We have been using a EVAL-ADICUP3029 with the CrossCore Embedded Studio and it's was working fine. Some day we tried to upload a need code when we were surprised with the following error message: "Error: command ignored for attempted access of a protected or out of memory location) Error: failed erasing sectors 0 to 20. Error: flash_erase returned -902". Then we tried reuploading a simple blink_example code and we faced the same issue. After that we were recommended to follow the guide "Unlocking a "Bricked" ADICUP3029". We were succusseful on the first tries, but it didn't solve the first problem. Now we can't even redo the Guide because we are now facing a "No autobaud response" problem. After that point we don't what else to do.

We looking forward for help.

Tiago Barros.

Parents
  • Hi, I had the same problem. In my case the UART connection with ADuCM3029, the model that I'm using, was wrong.

    So, the controller tries to send the autobaud response generated by CCES Seria Flash Programmer but the UART_RX pin wasn't connected correctly and the computer can't receive the response.

    After changing the connection, I did a successful erase. Just check if you have the same problem.

    Best regards,

    Flávio

Reply
  • Hi, I had the same problem. In my case the UART connection with ADuCM3029, the model that I'm using, was wrong.

    So, the controller tries to send the autobaud response generated by CCES Seria Flash Programmer but the UART_RX pin wasn't connected correctly and the computer can't receive the response.

    After changing the connection, I did a successful erase. Just check if you have the same problem.

    Best regards,

    Flávio

Children
No Data