ADICUP3029: not recognized

Hello,

I have EVAL-ADICUP3029 board. I followed all the instructions from https://wiki.analog.com/resources/eval/user-guides/eval-adicup3029 to configure the switches and connect the board to Win10 computer via USB. The board is never recognized upon connecting to a PC (I tried two different Win10 x64 computers). S2 switch is switched to "USB" and S5 to "Wall/USB". Using Reset didn't help either. Or reconnecting the baord to USB again. Installing mBed windows serial driver from https://developer.mbed.org/handbook/Windows-serial-configuration didn't help.

Thanks,

Dave

Parents
  • 0
    •  Analog Employees 
    on Jun 14, 2019 6:38 PM over 1 year ago

    Hi Dave,

    Is this a brand new EVAL-ADICUP3029?  Did you take this out of the box and run into this problem?  Or have you programmed this board before, and now for whatever reason you can't get this to show back up?

    Can you take a screen shot of the EVAL-ADICUP3029 plugged into your USB part and then take a screen shot of your windows explorer window?  I want to see if the DAPLINK drive is showing up at all.  The next thing to do would be to go to the device manager of the PC and find out which COM port this board was assigned to and ensuring that it shows up in that list.(should be called Serial Mbed or something to that effect)

    Cheers,

    Brandon

  • Hi Brandon,

    Thank you very much for your prompt reply. It's an out of the box board. Turned out it was a problem in USB cable, probably one of data wires was damaged so the board lights were on but the data didn't go through. I replaced the cable to a different one and now I see "DAPLINK" drive when I plug in the board on both computers.

    I'm not sure, however, if now the board recognized properly since when I progressed to "Start/Stop Debug session" in  basic "Blinky" example in qVision, I get  "Error: Flash Download failed - Cortex-M3" I have attached the parameters I used. 

    Thank you very much,

    Dave

  • Problem resolved. Some project options had to be changed. Also, I had to run Flash -> Erase first.

  • 0
    •  Analog Employees 
    on Jun 20, 2019 8:43 PM over 1 year ago in reply to davewb

    Thanks for writing back the answer.  Apologizes on getting back to you, I was out on business travel for a few days.

Reply Children