CCES 2.8.2 ADXL372DemoSuiteForADuCM3029.exe installation error

Hi 

I have EVAL ADICUP3029 with EVAL-ADXL-ARDX-INT and ADXL372Z-PIN (301-720)

Unable to install this. 

It seems it rejected the install because of newer version BSP does not sync with this. I could not find version 1.0.1 to make it work. 

I don't know where I go this ADXL372DemoSuiteForADuCM3029.exe last time. It was loaded from more likely AD website or elsewhere.