[ADICUP360]encounter an error message "unable to find CMSIS-DAP device".

Hello,

Congratulations releasing ADICUP360.

I have been trying to use ADICUP360 with following wiki information but encounter an error.

(I try to test blink project and GDB OPEN OCD debugger as following on Wiki instruction)


Eclipse fail to download elf file with error message as below.


Open On-Chip Debugger 0.10.0-dev-00025-g81cc011-dirty (2015-08-17-13:23)

Licensed under GNU GPL v2

For bug reports, read

  http://openocd.org/doc/doxygen/bugs.html

Info : only one transport option; autoselect 'swd'

adapter speed: 5000 kHz

adapter_nsrst_delay: 100

cortex_m reset_config vectreset

Error: unable to find CMSIS-DAP device

This error seems Eclipse cannot recognize ADICUP360 via USB port. (Because when I unconnected ADICUP360 with PC, Eclipse show the same error message as above.)

I suppose I miss something setting on ADICUP360 board.. But I can not figure out where is wrong...

Jumper and DIP SW setting are default.

I've tried also another ADICUP360 and other USB port and cable and several S1-S4 switch combinations but all fail.

I would appreciate if you have any suggestions.

Best regards,

Sofy

Parents
  • 0
    •  Analog Employees 
    on Feb 17, 2016 10:36 AM over 4 years ago

    Hello, Thank you for your response!

    Your advise is right. When I re-install Eclipse again, I encounter an error as below.

    It seems failing to setup USB driver.

    I've tried push "install" button many times but never proceed forward. So I have an only choice to push "Cancel".

    After finish setup, I encounter same error as my 1st message in this topic. (Error: unable to find CMSIS-DAP device)

    So my problem's root cause is probably missing mbed USB driver, I suppose.

    Then, I got latest mbed driver as below URL link

    https://developer.mbed.org/handbook/Windows-serial-configuration

    file name is "mbedWinSerial_16466.exe"

    After setup this latest driver, mbed COM port appeared on my device manager as below.

    But still error is appeared but message is different like as below.

    Error: unable to open CMSIS-DAP device 0xd28:0x204

    Before message is "unable to find" but now "unable to open"

    I had reboot my PC and try another USB port as well, but situation is still same.

    Thank you for your help.

    Sofy

Reply
  • 0
    •  Analog Employees 
    on Feb 17, 2016 10:36 AM over 4 years ago

    Hello, Thank you for your response!

    Your advise is right. When I re-install Eclipse again, I encounter an error as below.

    It seems failing to setup USB driver.

    I've tried push "install" button many times but never proceed forward. So I have an only choice to push "Cancel".

    After finish setup, I encounter same error as my 1st message in this topic. (Error: unable to find CMSIS-DAP device)

    So my problem's root cause is probably missing mbed USB driver, I suppose.

    Then, I got latest mbed driver as below URL link

    https://developer.mbed.org/handbook/Windows-serial-configuration

    file name is "mbedWinSerial_16466.exe"

    After setup this latest driver, mbed COM port appeared on my device manager as below.

    But still error is appeared but message is different like as below.

    Error: unable to open CMSIS-DAP device 0xd28:0x204

    Before message is "unable to find" but now "unable to open"

    I had reboot my PC and try another USB port as well, but situation is still same.

    Thank you for your help.

    Sofy

Children
No Data