ADUC7126 debug problem with JLink error when debugging with Keil

Hello,

I have a problem when debugging the ADUC7126 board with JLink.

I get the following error when trying to debug with Keil uVision5.26:

Load "C:\\Users\\MCabuena\\Documents\\bbu_LT8228_interface\\BBU_Project\\Keil\\Objects\\BBU_ADC.axf"
ProjectFile = C:\Users\MCabuena\Documents\bbu_LT8228_interface\BBU_Project\Keil\JLinkArm_BBU Project.ini
Device = ADuC7126
Info: Device "ADUC7126" selected.
VTarget = 3.335V
Info: ADI system TAP: Connecting to device with system TAP.
Info: TotalIRLen = 5, IRPrint = 0x11
DLL version V6.32i, compiled Jul 24 2018 15:19:55
Firmware: J-Link V11 compiled Aug 14 2019 16:21:09
Hardware: V11.00
Hardware-Breakpoints: 2
Software-Breakpoints: 8192
Watchpoints: 0
Found 2 JTAG devices, Total IRLen = 9:
Id of device #0: 0x4F1F0F0F
Id of device #1: 0x028031CB
ARM7 identified.
JTAG speed: 800 kHz
JTAG speed: 800 kHz
Full Chip Erase Done.
Programming Done.
Verify OK.
Flash Load finished at 13:14:20
Error: Target DLL has been cancelled. Debugger aborted !

I have tried using ARMWSD to erase the memory of the MCU. If I erase the memory using the ARMWSD, I can download the code, but when I use the debug of Keil, I get the following errors:

Software-Breakpoints: 8192
Watchpoints: 0

Found 2 JTAG devices, Total IRLen = 9:
Id of device #0: 0x4F1F0F0F
Id of device #1: 0x028031CB
ARM7 identified.
JTAG speed: 800 kHz
S/N : 71000537
OEM : MIDAS
Feature(s) : RDI, GDB
VTarget = 3.335V
JTAG speed: 800 kHz
Load "C:\\Users\\MCabuena\\Documents\\bbu_LT8228_interface\\BBU_Project\\Keil\\Objects\\BBU_ADC.axf"
Info: J-Link: Flash download: Bank 0 @ 0x00080000: 1 range affected (5120 bytes)
Info: J-Link: Flash download: Total time needed: 0.657s (Prepare: 0.069s, Compare: 0.030s, Erase: 0.242s, Program: 0.280s, Verify: 0.028s, Restore: 0.006s)
JTAG speed: 800 kHz
BS \\BBU_ADC\../FOR_DEBUG/src/adc_test.c\25
BS \\BBU_ADC\../Physical_Controllers/src/adc_controller.c\94
***JLink Error: Bad JTAG communication: Write to IR: Expected 0x1, got 0xF (TAP Command : 2) @ Off 0x5.

***JLink Error: Reading register 18 failed: Unspecified error
***JLink Error: Reading register 19 failed: Unspecified error
***JLink Error: Reading register 20 failed: Unspecified error
***JLink Error: Reading register 21 failed: Unspecified error
***JLink Error: Reading register 22 failed: Unspecified error
***JLink Error: Reading register 23 failed: Unspecified error
***JLink Error: Reading register 24 failed: Unspecified error
***JLink Error: Reading register 17 failed: Unspecified error
***JLink Error: Reading register 32 failed: Unspecified error
***JLink Error: Reading register 33 failed: Unspecified error
***JLink Error: Reading register 31 failed: Unspecified error
***JLink Error: Reading register 26 failed: Unspecified error
***JLink Error: Reading register 27 failed: Unspecified error
***JLink Error: Reading register 25 failed: Unspecified error
***JLink Error: Reading register 35 failed: Unspecified error
***JLink Error: Reading register 36 failed: Unspecified error
***JLink Error: Reading register 34 failed: Unspecified error
Cannot read memory
Cannot read memory
Cannot read memory
Cannot read memory
Cannot read memory
Cannot read memory
Cannot read memory

Can anyone suggest me what I should do to solve these errors?

Sincerely,

Marvin Neil