Post Go back to editing

Setting UART speed for ADI monitor in Keil uVision3

The settings of ADI monitor in Keil uVision3 seem to only allow to select the COM port, but not the COM port speed.  I tried to change the XTAL speed field in the ADI monitor settings and I tried to change the COM port speed in the Windows device manager, but both without effect on the ADI monitor UART speed. 

Is the communication speed of ADI monitor in Keil uVision3 set in stone to 9600 or is there a way to change that ?

Parents
  • Hi,

    You can change the port speed in the device manager. Select the COM port>properties>Port settings tab.

    Regards,
    Karl

  • You mean the Windows device manager ?  Or something inside uVision ?  As mentioned in my inititial question, I tried changing the port speed in the Windows device manager but uVision doesn't seem to use that setting. uVision seems stuck on 9600.

    By the way, I tried the same board with that higher port speed with WSD and it works.  Cause WSD seems to set the desired port speed directly. But I dont know what uVision does or if there is a config file for ADI monitor in uVision that allows more configuration than the  ADI monitor tab.  Unfortunately the ADI monitor tab in uVision only let's you set the port number but not the speed.

  • I was talking about the Windows device manager. I didn't notice you had already tried it.


    Are you setting the UART speed to monitor the UART of the device or for debugging in Keil?

Reply Children