Post Go back to editing

AD8495 Spice model cold junction compensation not working

Category: Hardware
Product Number: AD8495
Software Version: LTspice XVII(x64) (17.0.37.0)

Hello, 

When a voltage source is connected to the VCJC pin, the VOUT increases at 1mV / V applied to the pin.

 

This would indicate that the cold junction compensation does not work? 

Is there a fix for this? 

Best regards, 

Sam

Top Replies

  • Hello Sam,

    VOUT increases at 1mV / V

    I think it's 5mV/V (or 5mV/°C respectively). Your plot shows V(out)/5, and V(out)/5 varies by 50mV when VCJC varies by 50V or by 50°C respectively).

    This would indicate that the cold junction compensation does not work? 

    I think it shows, that the compensation does work.

    You change the cold junction temperature by 50° but you keep the thermocouple voltage constant (given by voltage source V4). A constant thermocouple voltage together with a changed cold junction temperature corresponds to a changed measured temperature - and that's what V(out) is showing.

    If the measured temperature would be constant and the cold junction temperature changes, the thermocouple voltage would also change - which is not the case in your simulation.

    best regards

    Achim

  • Hi  

    Thank you for reaching out and sharing your inquiries. 

    As  mentioned and I agree; your TC voltage must vary upon changing the CJC.  AD8495 is designed to have 5mV/°C transfer function.

    Thank you  for your initial response.

    Regards,

  • Hi Both, thanks for your replies. 

    The transfer function is 5mV / degC at the measurement junction, not the reference (cold) junction. If both the measurement junction and cold junction had the same transfer function it is not cold junction compensated.

    From the datasheet, the Ambient temperature rejection is 0.05 degC/degC as shown below:

    From this, if the cold junction(reference junction) was at 50 DegC, the maximum error would be 0.05 * 50 = 2.5DegC. 

    I've changed my sim so that the thermocouple voltage is a constant 6.138mV, which is the thermocouple voltage at 150DegC. I've set up a step param to step the voltage supplied to VCJC from 0 to 50 V, which equates to 0 to 50 DegC in steps of 10 degC at the reference/cold junction: 

    At 150 DegC, using the transfer function of 5mV/DegC, I'd expect to see a voltage of V(vout) = 150 * 5 = 750 mV.

    For a temperature of 0DegC at the cold junction, the V(vout) = 755.6mV. Calculating the measurement junction temperature(Tmj) from V(vout), Tmj = 755.6/5 = 151.12 DegC

    For a temperature of 50DegC at the cold junction, the V(vout) = 1.0056mV. Calculating the measurement junction temperature(Tmj) from V(vout), Tmj = 1.0056/5 = 201.12 DegC

     

    This shows that for a cold junction temperature of 50 DegC, the Tmj error is 50 DegC, indicating the compensation is not working - it should have a max error of 2.5 degC. 

    Am I using the VCJC pin incorrectly? 

    Best regards, 

    Sam

  • Hello Sam

    Am I using the VCJC pin incorrectly? 

    no. I think you misinterprete the function of the cold junction compensation (and maybe the working principle of thermocouples).

    I've changed my sim so that the thermocouple voltage is a constant 6.138mV, which is the thermocouple voltage at 150DegC.

    ok, let's take this setting for an example calculation.

    When a type K thermocouple delivers a thermovoltage of 6,138mV, that does not mean, that the temperature at the tip of the thermocouple is 150°C. It means, that the temperature difference between the tip of the thermocouple and the end of the thermocouple (the cold junction) ist 150°C. That's the way thermocouples are working: they give a thermovoltage which is proportional to the temperature difference between the front tip, where both wires are welded together, and the cold end of the thermocouple, where the transition from the thermocouple to copper wires happens.

    If the cold junction is at 0°C and the thermovoltage is 6,138mV, the front tip of the thermocouple is indeed at 150°C. In that case, the AD8495 should deliver an ouput voltage of 150°C*5mV/°C=750mV. That's what your simulation is showing in the lowest setting of VCJC.

    But if cold junction is at 50°C and the thermovoltage is 6,138mV, then the front tip of the thermocouple is at 150°C+50°C=200°C. Then the AD8495 should deliver 200°C*5mV/°C=1V. That's what your simulation is showing for the highest setting of VCJC. The cold junction compensation works exactly as it should. It measures the temperature of the cold junction, and takes this into account in calculating the temperature at the front tip of the thermocouple and amplifying that with 5mV/°C.

    For this to work well in reality you have to make sure that the cold junction (the transition from the thermocouple to the copper wires) and the AD5894 are very close to each other and have identical temperatures. Cause the AD5894 does not really measure the temperature at the thermocouple connector but the chip temperature and assumes that these values are close to each other.

    Ambient temperature rejection is 0.05 degC/degC

    The ambient temperature rejection does not describe the cold junction compensation as such. It describes the accuracy loss of the chip when the ambient temperature deviates from 25°C. So ambient temperature rejection does not describe how cold junction compensation is working. It describes the temperature dependence of error limits when cold junction compensation is already applied.

    best regards

    Achim

  • Achim, 

    This has cleared things up - you are exactly right. I wasn't accounting for the thermocouple voltage decrease as the cold junction temperature increased! 

    This is further illustrated by Table 6 in the datasheet: 

    I'll make sure to keep the AD8495 as close as possible to the cold junction to ensure they are at the same temperature.

    Thanks again for your help. 

    Sam