Post Go back to editing

Help needed with AD8420 design

Hello everyone, I have a problem with the AD8420 in-amp in a new electromagnetic flow meter design. Please refer to the attached image of a section of the circuit diagram.

The AD8420 is powered from a 3 V supply with the REF pin connected to mid-rail at 1.5 V. The inputs are AC coupled and there are 150k resistors to the 1.5 V supply to provide a path for the input bias currents. The gain is set at 151 with a 150k feedback resistor and a 1k resistor (R17) between the FB pin and the 1.5 V reference voltage. A 1k resistor is placed between 1.5 V and the REF pin. With this configuration one would expect the output to be at 1.5 V, but instead it sits at about 2.8 V. I measure (and calculate) about 8 mV across R17 which implies a corresponding 8 mV differential voltage at the input. However, the inputs are at exactly the same voltage.

I have tried to tie the two 'bias' resistors (R25 & R26 in the circuit) to ground; I have tried to remove the RF filter capacitors; I have tried changing the gain resistors; I have even tried cutting the trace between the output of the AD 8420 and the LTC6910. Nothing helps. The output stays near the upper rail. It is not a faulty device - three different prototype boards have the same problem.

I am now stuck, and I hope someone can shed some light on this problem.

Thanks.

Parents
  • Hi Chris,

    See the input range specification in the AD8420 datasheet. The inputs (as well as REF and FB) require 2.2V headroom from the positive rail. 1.5V is out of range for a 3V supply.

    You might be able to bias the inputs to 0V instead of 1.5V, but it may be more difficult to bring REF down into a working range and still get the output swing that you want. If that will be a problem, you might consider switching to the pin-compatible AD8237, which is recommended by our in-amp tool, along with AD8236 (not pin-compatible but notably for EM flow, it has very high input impedance).

    Another option that would work for the AD8420 would be to pull REF down to an intermediate voltage such as 0.5V and then use a pull-down resistor from FB to 0V in order to level-shift the output range back up so the output is centered around 1.5V. A similar idea is described in this article: How to Stay Out of Deep Water When Designing with Bridge Sensors

    Here's a sketch of this option:

    Best regards,

    Scott

Reply
  • Hi Chris,

    See the input range specification in the AD8420 datasheet. The inputs (as well as REF and FB) require 2.2V headroom from the positive rail. 1.5V is out of range for a 3V supply.

    You might be able to bias the inputs to 0V instead of 1.5V, but it may be more difficult to bring REF down into a working range and still get the output swing that you want. If that will be a problem, you might consider switching to the pin-compatible AD8237, which is recommended by our in-amp tool, along with AD8236 (not pin-compatible but notably for EM flow, it has very high input impedance).

    Another option that would work for the AD8420 would be to pull REF down to an intermediate voltage such as 0.5V and then use a pull-down resistor from FB to 0V in order to level-shift the output range back up so the output is centered around 1.5V. A similar idea is described in this article: How to Stay Out of Deep Water When Designing with Bridge Sensors

    Here's a sketch of this option:

    Best regards,

    Scott

Children
No Data