Post Go back to editing

AD5560 MEASOUT issue


Hi sir,

I am using AD5560 to as a power supply, meantime I read the current from MEASOUT pin, means, I use FVMI mode. I found a issue when read the value from MEASOUT pin, I must wait  long time then can read a correct value for MEASOUT pin. Here is the waveform I capure by a scope, the blue one is the force value, and the yellow one is the MEASOUT pin.

From the scope we also can see the force value achieve the corrent value quickly, but the MEASOUT value firstly reach a very high value, then after about 400ms begin to drop, after another 200~300ms then reach the correct value, I do not know where is wrong, can anyone give a hint?

Thanks

Best Regards

Dawei

Parents
  • Hi sir

         Have you solve the problem? We meet the problem too, the param is

         AVDD = 9V,AVSS = -9V;  FVMI;  5uA; gain 1; 

         The current is about 20 nA when the V is 3V ;

          When we set the output V to 3V; the measout pin need about 5s to  steady; 

          and when we set to 0V from 3V, the measout pin need about 5s to 0v too( 2s :90%); 

        The problem bring inefficiency to our equipment.

        Anyone can help me?

         Thanks very much

Reply
  • Hi sir

         Have you solve the problem? We meet the problem too, the param is

         AVDD = 9V,AVSS = -9V;  FVMI;  5uA; gain 1; 

         The current is about 20 nA when the V is 3V ;

          When we set the output V to 3V; the measout pin need about 5s to  steady; 

          and when we set to 0V from 3V, the measout pin need about 5s to 0v too( 2s :90%); 

        The problem bring inefficiency to our equipment.

        Anyone can help me?

         Thanks very much

Children
No Data