Post Go back to editing

LT1677-AMPLIFIER O/P LOOKS WEIRED

Dear Team,

I am developing a circuit which will convert a DC value of 2.8V to a square wave of value 2.8V and 3.3V. This is done by using an opamp as an amplifier and a transistor is used to as a switch to do this.But I can see output is not proper and it changes the duty cycle of output wave form.My input is 50Khz 0 to 3.3V squre wave.

Please find the attached circuit diagram and output waveform  .Could you please help me how to solve this issue.



tagged
[edited by: JValeriani at 2:32 PM (GMT 0) on 14 Oct 2019]
  • Hi harianalog,

    Firstly, set the rise time and the fail time to 1 picosecond value. Secondly, increase value of capacitor. Please, look at my results:

    It meets your requirements?

    Regards,

    Kirill

  • Hi Kirill,

    Thank you very much.I need few clarifications.

    Please find the attached image.Green is output wave form and blue is input waveform

    Regards

    Hari

  • Hi Hari,

    Deceleration of pulse fronts is caused by time constants of RC networks. The overshoots is caused by the recharging of capacity between gate and drain. To test these hypotheses, I use a simple amplifier model with no frequency correction.

    Step 1: capacitance between gate and drain 5 pF

    If control pulse increases recharge current flows through resistive feedback network from V2 to op-amp output and causes negative overshoot. If control pulse decreases recharge current flows from op-amp output to V2 and causes positive overshoot.

    Step 2: capacitance between source and drain 5 pF

    This capacitance causes increasing of pulse fail time.

    Step 3: capacitance of correction causes increasing of rise and fail time at once

    Combination all capacitances:

    Note that this is only a qualitative illustration but not quantitative.

    Probably an analog switch can replace the transistor here. Consider this option.

    I hope that this help you.

    Regards,

    Kirill

  • Hi Krill,

    When I am simulating my complete system,I am getting an error.

    Could you please  tell me why. Please find the schematic and error log

    Regards

    Hari

  • Hi Hari,

    How did you add TLV7011 model to LTSpice library? Note that first three lines in log refer to U4 component, try to find error there.

    Update: I have tried add this model in LTSpice. Unfortunately, syntax of TLV model is not compatible with LTSpice software. Try to find the nearest analogue in ADI portfolio.

    Regards,

    Kirill

  • Hi Kirill,

    Yes that is the issue with the model.

    The circuit which we discussed is converting a 0V to 3.3V digital signal to 2.8V to 3.6V digital signal.

    Do You have any other method to accomplish the same.

    Regards

    Hari