Post Go back to editing

ADA4940-2, issue on creating 2 differential signals around 0V

Dr Mr or Mrs,

 

I have designed and built a differential amplifier around the ADA4940-2.My goal is to convert two single ended signals (“deltaTune_ana” and “deltaLoad_ana”) :  each one from a dynamic of 0 to 0.4V to a dynamic of -0.2 to 0.2V.So the aim is to get  two differential signals centered around the ground with a gain of 1 and an offset of -0.2V from 2 single-ended signals. The circuit has been simulated on ADI DiffAmpCalc and then built.

 

Results on the circuit are not in accordance with the simulation : the negative supply falls in short circuit on the pcb.

I have then tried to use the ada4940-2 on your evaluation boad, with the same goals : gain of 1,offset of -0.2V and differential signals. The  positive power supply (3.3V), the negative one (-3V) and Vocm1=Vocm2=-0.2V are provided by external, low impedance and regulated power supplies. I noticed a gain of nearly one but an offset of approx -30 mV instead of -0.2V wanted.

I do not know the possible reason of this difference against the simulation. Do you have an idea ?

Extract of the scheme:

  • Hi ,

    Have you verified that the VOCM pin voltage is in fact -0.2V (as set by R5, and R6)? You may want to probe that node just to be sure, if not already.

    Regards,

    Hooman

  • On the PCB built, the negative power supply falls in short circuit and Vocm is not -0.2V.

    On the evaluation board, Vocm is provided from an external power supply and checked to be -0.2V.The output has not the -0.2V as wanted

  • Hi ,

    On the EVAL board (EVAL-AD7768-1) where you're measuring the incorrect output CM voltage (-30mV instead of the correct -0.2V), I assume you're driving only one input (e.g. AIN2+) from a 50ohm lab source / Generator. If so, how are you driving the other input (AIN2-)? If this is in fact your setup, then you should use a 50ohm to ground shunt termination on AIN2- if you're driving this diff amplifier with a single ended 50ohm source.

     

    Other than that, I don't see why you're not getting the correct output CM voltage.

    Regards,

    Hooman

  • Hi,

    Thanks for the answer.

    On the eval board(EVAL-FDA-2), AIN2+= 0 to 0.4V, +Vs=3.3V, -Vs=-3V, Vocm1=Vocm2=-0.2V are supplied from an isolated regulated power supply, like dp832 from Rigol.These voltages have been checked.

    As in the scheme given, AIN2- is connected to ground, resistances R67 to R70 are fixed to 4.99K and there are no resistances in R65 and R66

  • Hi ,

    I give up.

    I don't see anything wrong with your setup as you've described it! I don't have an explanation for why your measured output CM voltage (-30mV) is so far off from the applied VOCM voltage (-0.2V).

    I've drawn your schematic in LTspice and simulation as well shows no issues!

    Here is the simulation file (unzip to use):

    ADA4940 EZ output VOCM wrong 4_1_22.zip

    The only other suggestion I have is to run some test signal (step input) to make sure your circuit is not oscillating or somehow unstable? Incorrect offset voltages are possible if your circuit is not stable (e.g. decoupling caps not present, probe capacitance causing instability, etc.).

    Also, when you tie  the Dp832 DC power supply to AIN2+, it's best to decouple that to ground using a shunt cap to avoid the long cable tied to the input causing issues. Most times, I use coax cable and use a lab Generator instead with a 50ohm shunt termination on the EVAL board to avoid issues like that having to do with long uncontrolled cables hanging on a sensitive input node.

    Maybe other people can chime in with suggestions?

    Regards,

    Hooman

  • Hi, thanks for this simulation file and recommendation.I used the simulation file with an input of 0 to 0.4V as in our case (i have not checked the model of ADA4940 used)

    The output has a common mode of -0.2V wich is not the dynamic requested (-0.2 to 0.2V).

    Scheme + results below :

    Diff-Amp calculator gives another output which complies with the specs on output:

    For the stability I will check it.

    Regards

  • Hi ,

    I noticed that you mis-labelled (swapped) your "out_bar" and "out" nodes on the ADA4940 output pins in the LTspice simulation image you attached. The correct diff output swing with your conditions will be from 0V to 400mV as shown:

    Above seems to match the diff Amp Calculator image you attached.

    Regards,

    Hooman

  • I would like to convert two signals from 0 - 0.4V into -0.2 to 0.2V

    Diff-Amp calculator seems to confirm it is ok, seeing its output voltage Vdiff with the parameters given.Spice does not confirm it and a trial on eval board also, so i am wondering how to do it with the ada4940-2

  • Hi ,

    Sounds like you need to apply a voltage to the other ADA4940-2 input in order to compensate for your input having a 0.2V mid-point (0 to 0.4V input range you specified).

    I've done that in this simulation by applying 0.2V to R3 and increasing the gain:

    Simulation files (unzip before using):

    7140.ADA4940 EZ output VOCM wrong 4_6_22.zip

    Regards,

    Hooman

  • Hi, 

    With a bit late, thanks for this suggestion.

    By applying -0.2V to R3, this circuits can convert 0 to 0.4V to a balanced -0.2 to 0.2V .

    It has been checked on the eval board.